Nothing happen while openning Collabora


i’ve installed Collabora but nothing happen when i’m clicking on a odt file (or other files)(next screenshot). I’v checked several topics but nothing is similar to my problem (so far).

This is the first time I install Nextcloud on a server, and the first time I’m using docker, so I might have done some mistakes. But i really don’t see what.

Here are some information about my configuration (I tried to be the more comprehensive that i could).

my drive.aplicaen.conf

Alias /nextcloud "/var/www/nextcloud/"

<VirtualHost *:80>
 DocumentRoot /var/www/nextcloud/
 <Directory /var/www/nextcloud/>
  Options +FollowSymlinks
  AllowOverride All
  <IfModule mod_dav.c>
   Dav off

 SetEnv HOME /var/www/nextcloud
 SetEnv HTTP_HOME /var/www/nextcloud

RewriteEngine on
RewriteCond %{SERVER_NAME}
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

my collabora.aplicaen.conf

<VirtualHost *:443>
    Options -Indexes

  # SSL configuration, you may want to take the easy route instead and use Lets Encrypt!
    SSLEngine ON
    SSLCertificateFile /etc/letsencrypt/live/
    SSLCertificateChainFile /etc/letsencrypt/live/
    SSLCertificateKeyFile /etc/letsencrypt/live/
    SSLProtocol all -SSLv2 -SSLv3
    SSLHonorCipherOrder     on
  # Encoded slashes need to be allowed
    AllowEncodedSlashes NoDecode

  # Container uses a unique non-signed certificate
    SSLProxyEngine On
    SSLProxyVerify None
    SSLProxyCheckPeerCN Off
    SSLProxyCheckPeerName Off

  # keep the host
    ProxyPreserveHost On

  # static html, js, images, etc. served from loolwsd
  # loleaflet is the client part of LibreOffice Online
    ProxyPass           /loleaflet retry=0
    ProxyPassReverse    /loleaflet

  # WOPI discovery URL
    ProxyPass           /hosting/discovery retry=0
    ProxyPassReverse    /hosting/discovery

  # Main websocket
    ProxyPassMatch "/lool/(.*)/ws$" wss://$1/ws nocanon

  # Admin Console websocket
    ProxyPass   /lool/adminws wss://

  # Download as, Fullscreen presentation and Image upload operations
    ProxyPass           /lool
    ProxyPassReverse    /lool

#Include /etc/letsencrypt/options-ssl-apache.conf

i’v used let’s encrypt with certbot for both of my url to get my certifications and it works well (both url are in https when i’m connecting to it). But when i’m connecting to it just goes to my root folder is it normal ?

I’ve typed in my Collabora’s configuration in Nextcloud (sorry i’m limited to two screenshots, i can’t show it)

And this is the result i have when i check the docker’s logs.

I checked that proxy, proxy_wstunnel, proxy_http and ssl are enable. I followed those tutorials to get my installation done : Collabora Online Development Edition (CODE) - Collabora Office and Collabora Online & Collabora online - Nextcloud
I’m pretty sure i’v typed the correct url while installing the docker image (the one of my nextcloud) but is there a way to check that ? Could it comes from that ?

Well that’s all, i hope i was not too fuzzy and comprehensive. I’m not an english native speaker so sorry if my english is not that good. Thank you for reading me and, i hope, helping me.

Do you use uMatrix or ublock origin or something like that?

Not at all, and it does not work on any computer

I seem to have the same issue, allthough not using docker but the native Linux packages. Have’nt got an answer yet.

Can you check e.g. with web developer tools in firefox whether there is also an error 500 thrown at you, when opening a document? You should see it under the tab network analysis, when opening a file.

Yup i got an error 500 too !

I also check the php log ("/var/log/apache2/error.log") and got this error when i’m opening a document : [Sun Oct 21 10:10:10.393423 2018] [php7:error] [pid 11390] [client] PHP Fatal error: Cannot declare class GuzzleHttp\Handler\CurlFactory, because the name is already in use in /v
ar/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 16

Have you got something similar ? It seems to be a programing error… :confused:

edit : I’m using docker only for collabora, not for nextcloud. And strangely i haven’t got this problem if i use a snap package (but i don’t want to).

By the way, i fixed the issue in the docker’s log, and it’s not the cause of my problem.

I’m using docker only for collabora, not for nextcloud. And strangely i haven’t got this problem if i use a snap package (but i don’t want to).

Sounds like this is not a bug of collabora itself but of the nextcloud/server configuration. Which is weird, because i use the server config from the official website.

Does the snap package contain any configuration for collabora and can you take a look into that?

Hey ya’ll,

You can always try the VM script:

I’m not realy used to snap. So i didn’t find anything there…
I tried with the docker image of nextcloud in 14.3, same problem…
Not sure that the VM script will be usefull because it seems to come from nextcloud (or the collabora app in nextcloud) and not Collabora itself (the collabora interface is not showing up)

At first glance the configuration in the VM script does not differ from the config examples on the official website, does it?

Also it is using docker and apache. At least docker is no option in my case.

Okay, further investigations.

I tried to open with a shell browser and got a timeout.

I then did lsof -Pnl +M -i4 and found the following:

loolwsd  844      108   15u  IPv4 143563288      0t0  TCP (LISTEN)

So it is running on port 9981 even though the “documentation” says port 9980.

When accessing with a shell/text browser from the machine, i got a simple “OK” back.

So at least there is something running, it just does not do anything.

Is there maybe another way to edit .odt files? Collabora seems to be the only Option, as OnlyOffice doesn’t support odt. However i can not get it to work. :frowning:

Hi Moonlies, have you solved in some way?

Not sure about that? I use linux OS, have OnlyOffice local client installed and edited an ODT file just this morning?

what happens if you use different browsers to open the document?
it looks like I have the same issue:
I found out, that IE shows an error, Chrome anf FF not


I do not have IE at hand right now, but i could try it out some time when i have. However as i stated before, the developer tools show an http 500 error which at least shows that this is not a browser related problem…

Thanks for the hint! The last time i used OnlyOffice there only was the option to convert open document files into docx in order to edit them. But on their website they suggest this might not the case anymore (
I’ll definitely give it a try now!

Unfortunately not. :confused:

So apparently OnlyOffice can edit .odt files, so there is no reason for me to try to fix collabora.

1 Like

Okay guys, i found what was the problem in my case, when encountering the same problem with onlyoffice. The reason was, that iptables on my host was misconfigured and did not do port forwarding for packets coming from internal network via my external IP to another container on the private network. The detailed solution is here: So finally i found out what was the problem: As i had collabora and nextcloud on different VMs in the same private network but they were referenced by external urls, the firewall was not properly configured to do port forwarding in this case.

You can find the detailed solution here: