Nothing but a blank page after months of stable operation

Nextcloud version: 10.0.3
Operating system and version: Ubuntu 15.10 on an ARM Single Board Computer (Odroid XU4)
Apache or nginx version: Apache 2.4.12
PHP version : 5.6.11
Is this the first time you’ve seen this error and can you replicate it?: This is the first time it’s happened, but I can’t not replicate it.

The issue you are facing:
For a while now, I’ve had Nextcloud running on my XU4 without issues. However, as of yesterday, trying to load ANY Nextcloud page (including the login page) returns a blank page with status 304 and the following source:


As you might guess, webDAV access is non-functional too (with both the Nextcloud desktop client, and FolderSync on Android). I’ve tried reinstalling 10.0.3 and copying my config over (nothing changes, Nextcloud still doesn’t work), as well as upgrading to 11 (same result, plus PHP 7 is not available in Ubuntu 15.10’s default repos).
EDIT: I also tried resetting my configs to see if that would fix it. Nope. Same issue with a fresh config.

All other server applications on the system work fine (including other Apache-hosted pages and resources, and a few Node.js-based applications). I have not made any server changes in the last few days (other than a brief network disruption, i.e. I briefly disconnected and reconnected the Ethernet connection to fix an unrelated issue).

The output of your Nextcloud log in Admin > Logging:
(I can’t open the admin panel, obviously)

The output of your config.php file in /var/www/nextcloud/config:
<?php $CONFIG = array ( 'instanceid' => '[REMOVED]', 'passwordsalt' => '[REMOVED]', 'secret' => '[REMOVED]', 'trusted_domains' => array ( 0 => '', 1 => [MY EXTERNAL IP]', 2 => '[MY DOMAIN]', ), 'datadirectory' => '/media/HDD/nextcloud/data/', 'overwrite.cli.url' => '', 'dbtype' => 'mysql', 'version' => '', 'dbname' => 'nextcloud', 'dbhost' => 'localhost', 'dbport' => '', 'dbtableprefix' => 'oc_', 'dbuser' => '[REMOVED]', 'dbpassword' => '[REMOVED]', 'logtimezone' => 'UTC', 'installed' => true, 'appstore.experimental.enabled' => true, 'maintenance' => false, 'theme' => '', 'loglevel' => 2, );

The output of your Apache/nginx/system log in /var/log/____:
[Sun Feb 05 08:04:49.988505 2017] [ssl:warn] [pid 1331] AH01909: server certificate does NOT include an ID which matches the server name [Sun Feb 05 08:04:49.988805 2017] [ssl:warn] [pid 1331] AH01916: Init: ( You configured HTTP(80) on the standard HTTPS(443) port! [Sun Feb 05 08:04:49.989148 2017] [mpm_prefork:notice] [pid 1331] AH00163: Apache/2.4.12 (Ubuntu) OpenSSL/1.0.2d configured -- resuming normal operations [Sun Feb 05 08:04:49.989173 2017] [core:notice] [pid 1331] AH00094: Command line: '/usr/sbin/apache2'
Note: I use a Node.js-based reverse proxy to route all HTTP and HTTPS connections from the outside world to various internal services, and to provide the same TLS protection regardless of the backend service, so Apache’s weird port configuration and SSL errors are not an issue. I have tested my issue with both external (through the reverse proxy) and internal (direct connection to Apache) connections. Same issue in both cases.

you should be able to have a look at the logfile on your machine. you may find it in your data directory.

Ah, there it is! I’ve uploaded the last 1000 lines or so to pastebin here (pastebin didn’t like my full 3000 line log).

{"reqId":"l80maWaquXYj0fDwgVVe","remoteAddr":"","app":"core","message":"starting upgrade from to","level":0,"time":"2017-02-06T18:05:08+00:00","method":"--","url":"--","user":"--","version":""}

this is the last line of your log. so first guess: something went bad with the upgrade to

but 20 minutes earlier it states
{"reqId":"UBGPOrHbpzz8s3TtuBDS","remoteAddr":"","app":"core","message":"starting upgrade from to","level":0,"time":"2017-02-06T17:38:47+00:00","method":"--","url":"--","user":"--","version":""}

so you did an upgrade to before an upgrade to that looks quite messed up.
i have no idea what to do in this case. if i were you i would start over with a new installation.
or someone else has an advice (?)

I found the issue! A separate piece of software auto-updated, and started running lighttpd on port 80. This meant that many Apache-based pages, including Nextcloud, were being blocked out by lighttpd (although, weirdly enough, not my static assets folder). In any case, lesson learned: see what has updated recently, and make sure there aren’t any conflicting apps on the same port. I’ve now modified things so that the conflicting webapp also runs on Apache, and lighttpd never runs.

P.S. Is there a way I can mark this thread as solved?

glad it was way easier!

– message sent mobile –

you should be able to mark your own reply as solution