Note doesn't load on android app

I’ve tried loading several notes from my locally hosted Nextcloud instance. It just seems to time out, and doesn’t load. I tried removing the account, then re-adding it, and rebooting the phone, neither of which helped. Please advise.

  1. Ensure you have installed the correct app on your Nextcloud instance
  2. Move all your notes to another folder and impirt yout account to the Notes Android app
  3. Put your notes back step by step (for example 10 at once) and synchronize after each step

If you have lots of notes, a slow server or a bad infrastrucuture / network connection, the time won’t be enough to transfer all notes at once on the first import (see Consistent timeouts when syncing · Issue #761 · stefan-niedermann/nextcloud-notes · GitHub). After managing the first import, only the difference will be synchronized and timeouts shouldn’t occur anymore.

If this doesn not help, open an issue in our bug tracker and fill out the complete issue template so we can have a deeper look and try to help you.