Not enough storage error

Nextcloud version (eg, 18.0.2):
Operating system and version (eg, Ubuntu 20.04):FreeNAS-11.3-U1

The issue you are facing:
I have tried searching a few places but don’t seem to find any answers on how to fix my issue. Basically, i’ve installed nextcloud 19.0.0 on my FreeNAS-11.3-U1 box. I thought i got everything set up correctly, and i installed the windows client so i could just drop files from my pc to my personal storage. However, when i transfer files over (from windows explorer) i get the message that i don’t have enough storage.

I’ve confirmed that the data is flowing to the correct pool (I have my local data mounted to a different pool than my jail) and there isn’t any quota limits on my user. I have about 6 TB available, so i’m not sure why it keeps saying i’m maxing out.

I checked the user usage and it’s showing the user in red with 80GB data used. I’m not sure if i misconfigured the install so it’s looking at capacity from some other place.


Can you post more details? Filesystem outputs? Problems also in web-gui? Post screenshots.

Is it the NAS storage that is reported to be full, or is it the local disk in the PC?

The sync client will copy to the PC everything from the synced folder on the NAS, until either everything is synced, or you have 250MB left on the PC, in which case it will stop syncing,and whatever is not synced will be invisible from the PC.

If you have more data on the NAS than you have disk space for on the PC, the sync client will basically just fill your local disk.

aha! that was it, nextcloud was installed on my D drive, but it’s moving the synced folder to the c:/users/{username}/nextcloud folder.

is it possible to change the location of the sync folder?

Yes, you have to change it in the settings of the Next cloud app

1 Like

and i figured it out myself. for anyone else that runs into this, you just have to remove your sync folder from the windows app and re-add it back and just don’t select the default location. i didn’t realize what folder it was set to when i first set it up.

thanks for the help

Ok, good! Have a good day!