Non-standard sender address format in system emails (notifications)


When users of my Nextcloud get emails from the system/notifications (activity, test mails…),
the sender address is not in the standard format Full Name <>

In the admin panel I configured the address to be There is no setting to give a name to this address so I figured it must be somewhere in the code.

Users keep getting sender adresses like <> (test mail) or

"" <> <> (activity notification).

Is there a way for me to make sure that the sender address is always in the standard format? Something like

System Notifications <>

so that it will show the name as System Notifications in all email clients.

Thanks for your help.