Nochmal Probleme bei der Anmeldung

Hallo zusammen,

ich habe ein Problem mit der Anmeldung auf meiner NC-Installation, für einen User.

Die NC 22.2.3 Instanz läuft auf einem Server bei einem Web-Dienstleister als Teil meiner Webseiten.
Der Server läuft mit Debian 10.12
die Datenbank ist ein MariaDB 10.3.34
Der Web-Server ist ein Apache 2.4.38
und die PHP-Version ist 7.4.28
Diese NC wird von mir selbst viel genutzt. Und da liegt das Problem. Mit meinem (Nutzer)User dauert die Anmeldung sehr lange, führt in letzter Zeit sehr oft zu “504 Gateway Timeout”

Bruteforce Detection kann es kaum sein, erstens ist die Tabelle in der DB dazu leer und zweitens geschieht das von sehr verschiedenen Systemen in sehr unterschiedlichen Netzen immer gleich.

Da es der Haupt-Nutzer ist, und recht viele Daten, Kalender , Adressbücher (inkl verschiedene WebDav-Zugriffe) dort liegen, ist es immer sehr nervig, wenn ich erst zwei - drei mal mit einem anderen User anmelden muss um dann nach einigen Versuchen wieder mit dem eigentlichen User arbeiten zu können. Nach der Anmeldung funktioniert alles bestens.
Und bei allen Anderen Usern geht auch die Anmeldung zügig vonstatten.

Hat jemand eine Idee, wo ich suchen kann, um den Fehler einzugrenzen?
Hat jemand ähnlich Erfahrungen?

Danke schon mal an alle, die eine Idee haben

Gruß Jens

Falls du es wirklich per Webinstaller installiert hast, kann es schon sein, dass es grundsätzlich langsam ist bzw. vielleicht aufgrund deines umfangreicheren Benutzers langsamer wird. Solltest du Nextcloud intensiv nutzen, so solltest du über eine Managed Nextcloud nachdenken. Dein Web-Dienstleister hat Zugriff auf deine Daten, bei einer Managed Nextcloud wäre es nur ähnlich. Es ist eine Einbildung, dass du über eine Webseiten-Installation mehr Kontrolle hast als über eine Managed Nextcloud. Die Managed Nextcloud hat eher den Vorteil, dass sie für Nextcloud optimiert ist.

Aber trotzdem ein paar Ideen:
a.) Aktualisiere auf eine neuere Version, vielleicht löst es das Problem
b.) Nutze die Entwicklerwerkzeuge deines Browsers (F12) und dann Netzwerkanalyse. Siehst du dort irgendwelche Verzögerungen beim Laden der HTTP-Requests? Gibt es Fehlermeldungen?

Danke für diese Hinweise.
Als erstes habe ich mein NC aktualisiert. (23.0.4)
Dazu auf den System-Cron-Dienst umgestellt.
Dazu von einem mittel-starken Passwort auf ein starkes Passwort umgestellt.
Danach ging es 4 Tage gut. Heute wieder das gleiche Problem.
Nach ca. 2 Min. kommt “504 Gateway Timeout”.
Die Fehlermeldung über den Login-Versuch mit einem falschen Passwort kommt sofort.
Ich habe auch alle AddOns zur Filterung, WerbeBlocker und so abgeschaltet, woran es aber nicht liegen kann, auf dem Firmen-PC kann ich das nicht abschalten und da geht es auch manchmal und meistens erst nach mehreren Versuchen.
In einer parallel laufenden Admin-Session kommt keine Fehlermeldung um Log(wobei ich den Debug-Level ausgeschaltet habe).
Nach zwei drei oder vier Versuchen, auch mal mit dem falschen PW, geht’s dann auf einmal.
Wenn der Browser, die letzte Session noch im Cache hat, auch mal über Nacht, ist die Verbindung sofort da.
Wo kann ich suchen was kann dafür die Ursache sein.

Eine Analyse des Netzwerks mit den Browser-Hilfsmitteln (F12) ergibt keine Aussagen, da ja nichts zurück kommt, vom Server.
Diese Instanz läuft aus einem Root-Server, den ich mir leiste.und selbst administriere. Installiert habe ich die Instanz im CLI.

Danke und Gruß Jens

Manchmal verstehe ich auch nicht, warum einige Anwendungen (nicht nur Nextcloud) ewig auf irgendwas warten.

Du könntest mal dein Tuning optimieren. Vielleicht liegt es am Memory Caching. Was nutzt du davon?

Auch könntest du mal die Logs hochdrehen. Poste dann die Nextcloud Logs und evtl. auch Apache2 Logs.

Evtl. sind es auch Namensprobleme ode IP-Protokoll-Probleme. Nutze und konfiguriere nur einen Namen für deine Nextcloud. Deaktiviere auch mal IPv6. Prüfe evtl. auch noch deine Webserver-Einstellungen. Irgendwas besonders?

Hallo,

Hier ist mal meine config.php

<?php
$CONFIG = array (
  'instanceid' => 'ocuXXXxxxxxxxxx',
  'passwordsalt' => 'XXXXXXXXXXXXXXXXXXXXXXX',
  'secret' => 'XXXXXXXXXXXXXXXXXXXXXXXXXX',
  'trusted_domains' => 
  array (
    0 => 'meinecloud.meine-webseite.de',
  ),
  'datadirectory' => '/var/www/nexcloud/data',
  'overwrite.cli.url' => 'http://meinecloud.meine-webseite.de',
  'dbtype' => 'mysql',
  'version' => '23.0.4.1',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'xxxxxxxadmin',
  'dbpassword' => 'XXXXXXXXXX',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpsecure' => 'tls',
  'mail_from_address' => 'ich',
  'mail_domain' => 'meine-webseite.de',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'mein.e-mailserver.de',
  'mail_smtpport' => '587',
  'mail_smtpname' => 'ich@.meine-webseite.de',
  'mail_smtppassword' => 'XXXXXXXXXXXX',
  'default_phone_region' => 'DE',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'mysql.utf8mb4' => true,
  'app_install_overwrite' => 
  array (
    0 => 'groupfolders',
    1 => 'calendar',
    2 => 'event_update_notification',
  ),
  'updater.release.channel' => 'stable',
  'encryption.legacy_format_support' => false,
  'encryption.key_storage_migrated' => false,
  'memcache.local' => '\OC\Memcache\APCu',
  'memcache.distributed' => '\OC\Memcache\Redis',
  'redis' => [
     'host' => 'localhost',
     'port' => 6379,
],
  'data-fingerprint' => 'XXXXXXXXXXXXXXXXXXXXXxxxxxxxxxXXXX',
  'auth.bruteforce.protection.enabled' => false,
);

Tuning habe ich schon teilweise vor einiger Zeit gemacht, jetzt alles nochmal optimiert.
Momentan funktioniert es wiedermal gut.
Probleme mit Namensauflösung kann es nicht sein, andere User außer mein Hauptuser funktionieren ohne Verzögerung. Und IPv6 ist schon abgeschaltet.
Da eben alle anderen User tadellos funktionieren kann es eigentlich auch nicht der Web-Server sein.

Gruß Jens