No webdav and other errors!

Hey everyone!

Due to Covid19 and team members now working from home, I am trying to sort a solution for us to store our file, keep in touch with each other and keep things moving.

I’ve tried to install Nextcloud on our website cloud.thecannypantry.co.uk using the web installer. It has installed and there were no error messages during installation. However, things don’t seem to work. When I have looked in the settings>overview, there is a huge list of errors. I have taken a screenshot and hope someone will be able to help me get this up and running :frowning:.

My hosting provider has said that they don’t have WebDAV. As for the other errors I am not sure?

Any help would be appreciated so much!

Thank you in advance.

Where is the screenshot?

Apologies, added to original post.

For the strict transport security you need to go to your *.conf file and add this line.

Header always set Strict-Transport-Security “max-age=15552000; includeSubDomains”

Sorry for a stupid question, but where do I locate that file?

the issue with mounts.storage_id
Go to the folder where Nextcloud is ,and use this comand:
sudo -u www-data php occ db:convert-filecache-bigint

well , start looking here.
/etc/apache2/sites-available/nextcloud.conf

also evrytime you some change to this files ,restart the apache server

I have no idea how to do this? I am on shared hosting, so will I have access to the server? These are probably really dumb questions, but I have no clue. I just know some basic web stuff.

Okay, some warnings can be solved by your own, using the OCC Web app from the app store in nextcloud (like …mssing indices).
Some errors can be correted by modify the .htaccess file (e.g. Strict-Transport-Security)

Well you need to connect first to your server first over the SSH , then you can start making this adjustment. Do you know how to do this?

So my hosting panel says SSH access is enabled. But I have no idea how to do this? It is asking for a public key and handle?

ok then. You need to find the IP address of the server witch should be somewhere in the admin panel where your login. I will copy a link to some YouTube video where is really good explained. Principle is the same with all servers.

It is so complicated :frowning:

I’ve downloaded the OCC app and it seems to be less complicated but keep getting the error that the PHP memory limited is below recommended 512mb. I’ve set the PHP memory limited to 512mb but the error doesn’t seem to go away.

“imagick” muss be installed by your provider or if it is installed you have to activate it in your admin panel.

Also the linked documention of the messages willl help, too.

And check your provider package. Maybe the memory limit is set to 128 MB or 256 MB. But nextcloud will work with less than 512 MB.

Ah god, I don’t have the knowledge to do this.

Maybe there is another app out there that is easier to install and set up.

You can always install the SNAP version, there is almost non configuration. and its very easy

What is that SNAP version? Does it have the same functionality etc?

Yes its nextcloud ,only the whole configuration ,msql php apache is in one package. The easiest way is to do it on Ubuntu. But you will still acces to the terminal ,as you have to use a comand to download this and install. this vido explians it all.

As i understood the nextcloud instance is running on a shared server hosted by a provider.
I am running a instance on a shared server too. And i get also some warnings:


Okay, its german. Often on a shared server you can’t solve all warnings. But it works!

So let us solve this by using OCC Web:

This can be solved by modifie the .htaccess


by adding following at the bottom of your .htaccess:

Ok, I updated the .htaccess and it fixed that error! Yay.

No how do I fix the other errors using OCC Web?