No share icon displayed in files app

Hi,
I am using nextcloudpi with NC 15.0.2 and cannot see any share icons in the files app. The folders (update: they are now visible after making changes in the theme configuration) and file icons are visible.
Sharing app is activated.

Thank you for any suggestion,
kr,
Martin

Update: a

sudo -u www-data php occ maintenance:repair

did the trick.

Can you please tell me in which directory I have to be to use this command ? ( I’m a not expert with this system). And if you talk french it’s better for me.
Thank you.

In folder of your nextcloud installation. E.g. /var/www/nextcloud/

ooc command done , but no change.
Does these lines maybe could explain the problem ?
“PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/pdo_sqlite.so’ - /usr/lib/php/20151012/pdo_sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/sqlite3.so’ - /usr/lib/php/20151012/sqlite3.so: cannot open shared object file: No such file or directory in Unknown on line 0”

The folder /usr/lib/php is empty ; is it normal ?

Nope. Please check where is your php installed:

whereis php
php: /usr/bin/php7.0 /usr/bin/php /usr/lib/php ...

and check your php version if any.

php -version

Also you can check if you have needed modules:

php -module

List of needed modules for NC you can find here: https://docs.nextcloud.com/server/15/admin_manual/installation/source_installation.html#prerequisites-for-manual-installation Seems like you have wrong modules installed.

Database connectors (pick the one for your database:)

PHP module pdo_sqlite (>= 3, usually not recommended for performance reasons)
PHP module pdo_mysql (MySQL/MariaDB)
PHP module pdo_pgsql (requires PostgreSQL >= 9.0)

Which DB are you using? Check that it is the same that in your configuration in config.php:

grep dbtype /var/www/nextcloud/config/config.php

Thank you for your answer ; here is mine to your questions :slightly_smiling_face:
apc
apcu
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
hash
iconv
json
libxml
mbstring
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
Zend OPcache
zip
zlib

PHP 7.0.30-0+deb9u1 (cli) (built: Jun 14 2018 13:50:25

and whereis php

php: /usr/bin/php7.0 /usr/bin/php /usr/lib/php /etc/php /usr/include/php /usr/share/php7.0-gd /usr/share/php7.0-curl /usr/share/php7.0-readline /usr/share/php7.0-opcache /usr/share/php7.0-mysql /usr/share/php7.0-xml /usr/share/php7.0-json /usr/share/php7.0-zip /usr/share/php7.0-mbstring /usr/share/php7.0-common /usr/share/php /usr/share/man/man1/php.1.gz

It seems I use Mysql for Db

Here is all I can say about your qestions.
Thank you again for your help

Please check your NC configuration, because by calling php you have an error related to sqlite.

Check that you have:

'dbtype' => 'mysql ',

and not

'dbtype' => 'sqlite3',

Hello,
With this command, here is what I get :

" sudo -u www-data php occ config:list
PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/pdo_sqlite.so’ - /usr/lib/php/20151012/pdo_sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/sqlite3.so’ - /usr/lib/php/20151012/sqlite3.so: cannot open shared object file: No such file or directory in Unknown on line 0
{
“system”: {
“instanceid”: “REMOVED SENSITIVE VALUE”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“secret”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
meunier.perso.aquilenet.fr
],
“datadirectory”: “REMOVED SENSITIVE VALUE”,
“overwrite.cli.url”: “http://meunier.perso.aquilenet.fr”,
"dbtype": “mysql”,

Is it enough or must I give you more info ?

Try to specify PHP version like following, may be your environment pointing to php 5x:

sudo -u www-data /usr/bin/php7.0 occ config:list

It could be that it is ok, try to install modul that causes an error:

aptitude install php7.0-pdo-sqlite

I’ve done the command you say (sudo -u www-data…etc) and I’ve always the same answer :

PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/pdo_sqlite.so’ - /usr/lib/php/20151012/pdo_sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library ‘/usr/lib/php/20151012/sqlite3.so’ - /usr/lib/php/20151012/sqlite3.so: cannot open shared object file: No such file or directory in Unknown on line 0

How can I know where my environement is pointing ?

I’ve try to install php7.etc…, and here is the answer

“php7.0-pdo-sqlite” exists in the package database, but it is not a real package and no package provides it
Unable to apply some actions, aborting

I’m lost, and anyway I thank you for the help already done.

Google say you should try to check if your extension pdo_sqlite.so is enabled:

grep -Hrv ";" /etc/php/7.0/ | grep -E "extension(\s+)?="

and disable it :smile: in php.ini in folder of apache2 and/or cli, or fpm if you are using it for .e.g http 2.0.
Check this out:

UPDATE: you can use command to enable/disable modules: phpdismod

  • phpenmod moduleName enables a module to php7 (restart apache after that sudo service apache2 restart )
  • phpdismod moduleName disables a module to php7 (restart apache after that sudo service apache2 restart )
  • php -m lists the loaded modules

This morning everything went back alright , a new update and the sharing works.
Thank’s to everybody, you and the Nextcloud community who fix the problem.
As we say in french : “plus de peur que de mal”.

1 Like