No photo thumbnails for shared folders via links

Nextcloud version (eg, 20.0.5): 28.0.1
Operating system and version (eg, Ubuntu 20.04): Debian 12
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.57
PHP version (eg, 7.4): 8.2.7

The issue you are facing:

Hello I have issue with thumbnails with share link. Standart user thumbnails is okey but when I create share link it shows only default thumbnails.

Is this the first time you’ve seen this error? (Y/N): (Since instalation)

Steps to replicate it:

  1. As user create share
  2. Open share link to photo
  3. Only default thumbnails is there
  4. all images points to:
/index.php/apps/theming/img/core/filetypes/image.svg?v=ac3478d6

The output of your Nextcloud log in Admin > Logging:

empty

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => 'xxxxxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxx',
  'secret' => 'xxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' =>
  array (
    0 => 'xxxxxxxxxxxxx',
    1 => 'xxxxxxxxxxxxx',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '28.0.1.1',
  'overwrite.cli.url' => 'https://xxxxxxxxxxxxx',
  'overwriteprotocol' => 'https',
  'dbname' => 'xxxxxxxxxxx',
  'dbhost' => 'xxxxxxxxxxx',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxxxxx',
  'dbpassword' => 'xxxxxxxx',
  'installed' => true,
  'default_phone_region' => 'CS',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'xxxxxxxxxxxx',
  'mail_domain' => 'xxxxxxxxxxx',
  'mail_smtphost' => 'xxxxxxxxxxxxxxx',
  'mail_smtpport' => 'xxx',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'xxxxxxxxxxxxx',
  'mail_smtppassword' => 'xxxxxxxxxxxxxxx',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/run/redis/redis-server.sock',
    'port' => 0,
  ),
  'ldapProviderFactory' => 'OCA\\User_LDAP\\LDAPProviderFactory',
  'defaultapp' => 'files',
  'maintenance' => false,
);

Thanks for any help to configure thumbnails for shared links.

Hello,

I made update and on version 28.0.2 its still same. Thumbnails not work for sharing with passowrd.

Thank you for any tips.