No more versioning: Nextcloud versions app doesn't work with snapshot app

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 22.2
Operating system and version (eg, Ubuntu 20.04): ubuntu 21.04
Apache or nginx version (eg, Apache 2.4.25): apache with reversed nginx proxy
PHP version (eg, 7.4): 8.0

The issue you are facing:
No more versioning by the Versions App. Nothing to see in the nc web-app and nothing to see in the /data filesystem. Only entry’s of weeks ago, no new entry’s

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Versions App in place and running
  2. Install Snapshot App
  3. Config Snapshot App, try it out and test it
  4. Don’t use Snapshot App any further but leave it on system

The output of your Nextcloud log in Admin > Logging:

not applicable

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

not applicable

The output of your Apache/nginx/system log in /var/log/____:

not applicable

Hello all,

For days I was trying to find the root-cause of not having working versioning (nextcloud versions app) anymore. Lucky enough to discover this by the way. Nothing to find in logs, everything worked perfect. I tried and tried bij installing and disinstalling but nothing.

Suddenly I thought of the snapshot app (btrfs and zfs) I tried 2 months ago and never use anymore.
And yes! Turning off this app solved my problem solving sickness. Nextcloud versioning stops with everything without giving a single warning or logitem!!!

In my opinion versioning is a core-functionality (the V in webDAV) of nextcloud. It is bad that it stops functioning when a ‘random’ app is installed.

This is a very big flaw that has to be fixed inmediately. At least there has to be explicit warnings when installing the Snapshot App. Installable apps must be forbidden to touch the core functionallity of nextcloud.

I hope I can herewith help somebody,