No hair left to pull out - Collabora Config

Hi all, can anybody help please.

I am having a frustrating time configuring Collabora. I think its something fundamental but I just cant get it. I have followed the NC installation guide and pulled the docker down using my primary NC domain name as below.

sudo docker run -t -d -p -e ‘domain=redford\.duckdns\.org’ --restart always --cap-add MKNOD collabora/code

Then ran the required Apache commands

apt-get install apache2
a2enmod proxy
a2enmod proxy_wstunnel
a2enmod proxy_http
a2enmod ssl

and also created a collabora URL separate from my NC one. I have included a Virtual Hosts file in /etc/apache2/sites-available and added the cert, fullchain and privkey links.

<VirtualHost *:443>

SSL configuration, you may want to take the easy route instead and use Lets Encrypt!

SSLEngine on
SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateChainFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on

Encoded slashes need to be allowed

AllowEncodedSlashes NoDecode

Container uses a unique non-signed certificate

SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

keep the host

ProxyPreserveHost On

static html, js, images, etc. served from loolwsd

loleaflet is the client part of LibreOffice Online

ProxyPass /loleaflet retry=0
ProxyPassReverse /loleaflet

WOPI discovery URL

ProxyPass /hosting/discovery retry=0
ProxyPassReverse /hosting/discovery

Main websocket

ProxyPassMatch “/lool/(.*)/ws$” wss://$1/ws nocanon

Admin Console websocket

ProxyPass /lool/adminws wss://

Download as, Fullscreen presentation and Image upload operations

ProxyPass /lool
ProxyPassReverse /lool

Endpoint with information about availability of various features

ProxyPass /hosting/capabilities retry=0
ProxyPassReverse /hosting/capabilities

Literally followed the guide step for step but cannot seem to successfully add the URL in the server config for collabora in NC settings. When I try and go direct to the URL it just shows the Debian default apache page.

Also when I run docker I see

Containers: 3
Running: 0
Paused: 0
Stopped: 3
Images: 2

I would recommend using the built in collabora server, until you get this fixed

1 Like

Try without the https

Hi and thanks. How do I do this. I don’t have a built in Server and when I try and use the ARM CODE server, I don’t get the option to select it.

1 Like

what is your nextcloud version?

Try the other CODE app.

Its 20 but I forced an upgrade on 19.03 and didnt get the built in server. Thats exactly what Im after

1 Like

am also seeing no dockers running when I run docker ps

1 Like

Hello Baggers,

i hope my advice may helps you a bit. Collabora Online is running more smoothly with an own subdomain.
exp. nc.yourdomain is for your nextcloud and your CO has get another subdomain exp. office.yourdomain.
Collabora only accept https traffic from a seperat ip adress. Your Collabora-container is required to run o another machine with another ip adress than your NC instance.
If you are working on a raspberry pi: I am not sure if theire is an supported version for the arm architecture for the raspberry pi cpu. In the worst case use a machine with a x86 cpu.
At least it’s working for me. But I realy know the frustration with CO, so a weak ago i changed to Only Office.


Thanks mate, is Only Office more straight forward to set up ?

My apache2 Virtual config shows below which I think looks right

VirtualHost configuration:
*:80 localhost (/etc/apache2/sites-enabled/000-default.conf:1)
*:4443 localhost (/etc/apache2/sites-enabled/ncp.conf:2)
*:443 is a NameVirtualHost
default server (/etc/apache2/sites-enabled/collabora1.conf:1)
port 443 namevhost (/etc/apache2/sites-enabled/collabora1.conf:1)
port 443 namevhost (/etc/apache2/sites-enabled/nextcloud.conf:2)
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
PidFile: “/var/run/apache2/”
User: name=“www-data” id=33
Group: name=“www-data” id=33

1 Like

Just tried Only Office and unfortunately no support for ARM 64

1 Like

my guess at this point colla is also (maybe) not supported for arm. But I only can gues because i am using x86 only. At least for NC.

One solution could be to run the Collabora Online ore Only Office instance on a cheap vm hosted by an ISP and connect it to your local raspberry pi instance.

1 Like