No contacts appearing on the map but all else seems OK

Contacts app works fine. I installed Maps 0.2.4. All contacts with an address field show in oc_maps_address_geo and every field has the correct lat and long. Contacts appeared at first but then all disappeared. Don’t know why. Tried upgrade to Maps 0.2.5 but that made no difference so now I back to ‘stable’ version. One other weird thing is that there is one contact category appearing in Maps that once may have been in Contacts but hasn’t been there for at least a fortnight. I’ve deleted the vcf file showing in Maps and upload the latest version that Contacts uses. As I say Contacts works fine. All contacts and categories are consistent with uploaded vcf file. Apart from the rogue category that shows up in Maps all other contacts in Maps are equal in number to those in oc_maps_address_geo. BUT none of these contacts show on the map itself. I’ve tried the photos and tracks feature too but neither of these produces anything on the map itself.