No connection to Pi (SSH/Web) after apt-upgrade on NCP

Hi guys,

I just set up a fresh installation of NCP (NextCloudPi_RPi_03-09-19) on a Pi 3, enabled SSH via the ssh file on boot partition and logged in over SSH. Then I changed the standard password for the user “pi” and did a “apt update” and “apt upgrade”.

After a reboot I can’t connect to the pi. SSH gives me the error:
ssh: connect to host 192.168.178.100 port 22: No route to host

Trying the web-gui on port 4443:
ERR_ADDRESS_UNREACHABLE

When apt upgrade asked me, if i wanted to keep current files or use new files, regarding php (ini)files I choose to keep the current ones. Here is the console output:
https://pastebin.com/HQ0br52U

I can imagine that the Apache update broke web acces but why SSH?

Help is appreciated :slight_smile:

are you sure that’s the correct IP?

Hi @nachoparker,

yes, I checked my routers interface, i tried restarting the pi several times and also gave it different IP from the router but nothing changed… I also tried to ping it but its unreachable

Did you try to connect it to a screen and see if it even boots? If you can not ping it, the os seems to be not booting at all

Will try when returning from work and report back!

OK, @nachoparker I know this sounds crazy, it took me some time to figure it out:
Every time I took the pi to my workstation and connected display, keyboard, and another patch cable it worked. It did boot and was available over SSH, Web etc.

When moving it back to the router it didn’t work (in headless mode). I switched patch cabels, AC adapter, nothing worked. So I moved my display to the pi near the router and got the error message, saying that dhcp could not start so no ip address of course. When plugging in my keyboard (its a usb dongle for a logitech wireless keyboard) it started working!

I tried several times: Keyboard connected, no problems. No keyboard connected, dhcp fails and no network. Just now i connected the keyboard while the timeout for dhcp is displayed, few seconds later it gets an ip address!

What the hell is going on here?? I have no explanation for this and I need the keyboard for my workstation :laughing: