No connection to Nextcloud Talk possible with domain

I have an issue with nextcloud Talk that I can’t figure out how to solve.

Since Nextcloud Talk is available, I tried to use the app on iOS. However, it does not work when I use my domain ( → wich is

If I try to connect to it via my dns name, the error I receive is “Nextcloud not found”. However, the regular nextcloud app is fine with this and does work perfectly fine.

When I use the dynamic ip to connect with Nextcloud Talk iOS then it works (after adding the ip address to the allowed hosts list).

So far I tried:

  • different (new) hostname on
  • different ports (443 and custom ports)
  • completely new install of nextcloud 21 in a new Ubuntu server VM - today.

always the same result. The ip adress works fine, the hostname in the regular app also fine - but the nextcloud talk app does just not work with the hostname.

Did I miss something in the configuration that I can try?

Any idea on this is very much appreciated

Did you solve your problem? I have the same problem.

Ich habe leider das gleiche problem , hat jemand eine Lösung gefunden oder einen Vorschlag womit man versuchen kann ?

ich habe gerade eben das Problem gelöst :grinning:

man muss einfach den Port 80 von Router aus offen lassen da wahrscheinlich nexcloudPI Talk benötigt mindestens die Port 80 und 443

I am also having this problem… I’m using a wildcard cert from Let’s Encrypt.

Using the Android apps, both Nextcloud and Nextcloud Talk apps work great from inside my LAN and from externally.

Using iOS, Nextcloud app works inside and outside, but Nextcloud Talk will not connect when connected to my LAN, only if I disconnect WiFi and connect via the mobile network. :frowning: