No built-in updater button on 17.0.9

Nextcloud version (eg, 20.0.5): 17.0.9
Apache or nginx version (eg, Apache 2.4.25): Apache on shared hosting
PHP version (eg, 7.4): 7.3.21
Database: MySQL 5.0

The issue you are facing:

I wanted to Update our NC 17.0.9 but there is just no way for checking for a new version. I tried several resolutions that helped other users but nothing worked. The log does not really provide any errors that are connected to something with updates. Is there a way I can “restart” the update check by FTP oder web interface? As mentioned I use shared hosting so no full access via SSH.
Thank you

Is this the first time you’ve seen this error? (Y/N):
Steps to replicate it:

  1. Login with Webbrowser into your NC
  2. Settings
  3. Overview

The output of your Nextcloud log in Admin > Logging:
Nothing unusual about updater or version check

Looks a bit like the query of the update-server is not received yet (or blocked). First backup (data, config files, database).

I’d try a manual upgrade. You remove all the code and just keep the data folder and the config folder. Then you can place the new code of NC 18 (Changelog – Nextcloud). If you open Nextcloud on the browser the next time, it lets you update the setup. If you have SSH access, it’s better to run the occ upgrade command from ssh terminal.

Login checkout all your apps to make sure everything is working and correctly installed in NC 18. At least backup the database to not loose this step and go again to upgrade to NC 19 in order to use a still supported version.

Thanks. Wouldn’t it be safer to install 17.0.10 this way and see, if the updater starts working again? Or reinstall 17.0.9? Because with any previous update there were always issues when updating with the built-in updater. And I’m just more hopefull that, if the main version (17) stays in place, NC might start working “normally” before I update to v 18 and above.

You can go to 17.0.10, it’s even recommended to go to the last release of the same major branch.

1 Like

Hi Andrew

Just a little side note about something I noticed while reading your post. I saw that you are still using MySQL 5.0. Nextcloud 20 requires at least MySQL 5.7 and Nextlcoud 21 MySQL 8.0. Consider to upgrade your database too, to avoid further problems while upgrading to the latetst and greatest version of Nextcloud.

Thank you very much bb77.
Just upgraded to MySQL 5.7.33-1 - (Debian) so it’s ready for the future.

1 Like

So after a few weeks of trying and backups I managed to install NC 19.0.10
The main problem was an app (Group Folders) that made every step super difficult. But without this app NC is useless for what I need it.

With NC19 everything seems to work more or less, but the built-in updater is still missing. I tried to de-/activate several apps and see if that works but nothing helps.

Is it possible that this error comes from the /config or /data folders or the database that is somehow linked to them? Because those are the ones that I did not touch/delete with every new NC version/update via FTP.

Hi @Andrew0, try this in a shell : sudo -u www-data php /var/www/nextcloud/updater/updater.phar
This is the built-in updater in command line.

In your config.php :
this lines is set or not ?


if yes, delete them.

1 Like

Oh my god thank you @Mageunic :heart_eyes:
I don’t have access to full shell with sudo command as it’s shared hosting.
But those lines did the trick


Both were in the config file and set to false. Removing those lines brought me back the built-in updater yaaaay :blush:

1 Like