Nginx reverse proxy funktioniert nicht

Hallo, ich habe jetzt ein paar mal experimentiert aber finde den Fehler nicht.

Ich möchte lokal in meinem Netzwerk eine https Verbindung zu nectcloud aufbauen.

Sieht jemand meinen Fehler?
http://192.168.178.36:8822/ funktioniert.

Ich würde gern https://192.168.178.36/nextcloud verwenden.

server {
    listen 80;
    server_name 192.168.178.36;
    return 301 https://$server_name$request_uri;
}

server {
    listen 443 ssl;
    server_name 192.168.178.36;

    ssl_certificate /etc/ssl/certs/nginx-selfsigned.crt;
    ssl_certificate_key /etc/ssl/private/nginx-selfsigned.key;

    client_max_body_size 0;
    underscores_in_headers on;

    add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;

    location /nextcloud {
        proxy_pass http://192.168.178.36:8822;
        proxy_set_header Host $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
    }
}

Als Rückmeldung erhalte ich gerade:

Nextcloud
Seite nicht gefunden
Die Seite konnte auf dem Server nicht gefunden werden oder Sie sind nicht zum Anzeigen berechtigt.

Zurück zu Nextcloud

Nextcloud – ein sicherer Ort für all Ihre Daten

Schaue dir die reverse proxy docs an. Ich vermute du hast die OVERWRITE* Parameter nicht (korrekt) konfiguriert.