Nginx Proxy Manager + Collabora built-in CODE server

Hello

I have a very fresh installation of Nextcloud (official Docker Hub), running behind Nginx Proxy Manager (jlesage/nginx-proxy-manager), on an Intel x86-64 home server. I’m trying to get the Collabora built-in CODE server to work.

The CODE app installed successfully. The Collabora Online app says “Collabora Online server is reachable”. But when I try to open any kind of office file, it gives one of two errors:

Failed to load Collabora Online Development Edition - please try again later

Connection to server lost

This advice from Collabora seems to be the most promising avenue for troubleshooting: Connecting Collabora Online built-in CODE Server with Nginx - Collabora Office and Collabora Online

However, when I added the line to Nextcloud’s “Custom Nginx Configuration” in Nginx Proxy Manager, it immediately gives this error:

Command failed: /usr/sbin/nginx -t
nginx: [emerg] location "/" is outside location "^\/nextcloud\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy)\.php(?:$|\/)" in /data/nginx/proxy_host/5.conf:49
nginx: configuration file /etc/nginx/nginx.conf test failed

Admittedly, the advanced section of NPM is foreign to me. I only vaguely know what this line is trying to do - and I don’t know how to troubleshoot the error it’s giving. Has anyone gotten this to work, or have any advice for what I should be doing in NPM? Any help would be much appreciated.

Thanks!

Did anything ever come of this? I am having the same issue.

Nope, nothing has come of this. I haven’t tried again with the newer versions since I got the error in May.

I just tried again with Nextcloud 22.1.1 and the built-in CODE server works great! No configuration necessary. I just installed the built-in CODE server and the Collabora app and documents immediately were able to open in NC.

Ugh. Nevermind. I was trying at the local IP address, not behind NPM. When I try with NPM at port 4, I get the same CODE error (“Failed to load Collabora Online - please try again later”)