NextCloudPlus: Unable to connect from outside LAN

Flashed NCP onto my raspberry pi 3 B and ran through the initial config without any trouble. Got a DDNS account set up through FreeDNS, and that’s all running smoothly. Forwarded ports 80 and 443 to the pi, cleared them through the firewall, tried setting to to DMZ, disabling the router firewall, even tried reconfiguring NCP to use ports 8080 and 8443 instead of 80 and 443, but whatever I try to do, either by direct IP address or through the domain name, no requests actually arrive at my server. HTTPS requests time out, and regular HTTP requests always return a page with this text:

The connection to ‘x.x.x.158’ failed.
Error: TimedOut (0x274c).
System.Net.Sockets.SocketException A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond x.x.x.158:8080

What’s going on here? Is my ISP blocking inbound connections upstream?

If you’re able to access the server within your network but cannot from outside, then the issue is not with the Nextcloud server.

You can test yourself whether or not the ports are open: