NextcloudPlus TOTP not working

I have a default nextcloudPI installation (+done all updates) and facing problems with the standard TOTP app:

After activation the app, I try to enable it in the users security menu. After clicking the checkbox it turns into a spinning wheel. The QR code appears but the spinning wheel never disappears. When leaving the page and visiting again the TOTP is disabled again (so the state can not be save for some reason).

I also installed ntp und the machine to be sure time is running correct. Still no success.

BR, Michael

  • Debian 9 stretch
  • Nextcloud Version 13.0.2
  • Apache 2.4.25, with HTTP2 enabled
  • PHP 7.0
  • MariaDB 10
  • [Redis] memory cache ( [NEW 11-12-2017] )
  • 4.9 Linux Kernel ( NEW 03-13-2017 )

To do an installation of TOTP you have to :

1- Install it from the Application Store
2- Into your User Settings -> Security
3- Generate recovery codes… save them where nobody can find them
4- Activate TOTP,
5- Lunch your TOTP application in your smartphone for exemple, add a new service, scan the QR Code
6- Get a verification code (6 numbers)
7- Write them in the case on your web browser and click Verify

Once all that done, you’re good to go and it’s activated for your user…
Get in PM with me if you want me to try it on a new user.


Thank you for your quick reply.
It was about the backup codes. I generated new backup codes and then it worked immediately. Thank you!

So now it’s okay, modify your Topic to close it, you have a little box on your first sentance, when clicking on it you can choose witch post gave you the answer/solution and then it close your topic