Nextcloudplus no WebDAV access

Hello everybody.

There ist another issue I got.

Yesterday I put Nextcloud 13 on my Raspberry Pi 3 MB.
I can access my user accounts via browser and nextcloud android app and nextcloud app on iPad.

Now I would like to integrate a user account in the windows explorer. Unfortunately it does not work.
When I use https://cloud.local/nextcloud/remote.php/dav/files/USERNAME/ it shows that the folders is invalid.
Using “Cyberduck” it does not work either. It shows “unexpected response(405 Method not allowed)”.
Using “WebDAV Nav” on my iPad it shows the same 405-Error.

Some more informations:
Router: TP-Link TL-WR841N behind Hitron Cable Router in bridge mode
DDNS Provider: NO-IP
Internet company: Vodafone

How can I fix this issue?

Thanks Daniel

Try https://cloud.local/nextcloud/remote.php/webdav/
and authenticate with username and password

Thanks for your quick response.

The link redirects me to the file folder of my user account. But there is still no access from windows explorer neither cyberduck.

It seems it is a deeper problem…

This is realy strange, I have set up my RaspPi (yesterday) also with
NextcloudPlus and its is running without any problems.
I think there must be something wrong with your setup.
Are there any unusual changes you did? (other than the wizzard [initial
with http] https://raspberrypi:4443/ )

Maybe someone else sees more than me.

If you log into the web page for your server (the user/files one, not the control panel) and select settings in the bottom left corner the page that appears has the webDav URL for that user in the bottom left hand corner.

It should be something like

https://“address of your server here”/remote.php/webdav/

Some more details are in the thread I had on this topic a week or so ago:

Since I use NCP(last year) WebDAV never worked. So I gave it another try installing a fresh NCP 13. I did that three times in the last few days. I did it step by step using the github wiki. I did not even change nothing.

I could open the link https://cloud.local/nextcloud/remote.php/webdav/ in Firefox giving an exception for the certificate.
When I try to open the same link in Edge or Chrome oder Internet Explorer it does not work. It says that this site does not exist. And there is no option to give an exception as well. This is strange isn’t it?

Since a few hours I can access via cyberduck even though I did not change nothing!! But it still does not work with Windows Explorer or with my iPad.

I did so yesterday. In my last comment I already said that since a couple of hours I a can access via cyberduck. But Windows Explorer and WebDAV nav remain with the same error.

Any more ideas?

When you say “doesn’t work”, what exactly do you mean?

I had some issues with some apps/viewers due to my current lack of a security certificate (I’m using a DDNS via my router maker, so their generic domain is rather swamped at LetsEncrypt so getting one of their 20 certs a week for that domain is tricky).

Currently mine works with CarotDAV and Cyberduck (but with security warnings) but not with some of the other routes as rather than telling you there’s a security risk (due to lack of cert signing authority) they just reject it.

If your refer to my first post it is I cannot access WebDAV from Windows Explorer. When I map the WebDAV adress I get an error message: "The folder you entered does not appear to be valid. Please choose another"
When I try to access from WebDAV nav the message is “unexpected response(405 Method not allowed)”

If you refer to my third post: I could not open https://cloud.local/nextcloud/remote.php/webdav/ in Chrome or in Mircrosoft Edge. It says that this site does not exist.

And in this moment that link does not work anymore in Firefox. Accessing via cyberduck does not work either!!! Once again I get the error message “unexpected response(405 Method not allowed)”. :rage::rage::rage: I have changed nothing since yesterday.
Could it be a hardware problem? I mean it never worked. Then yesterday it worked with cyberduck. And today it does not work once again…

Are there any more ideas?

I had the same problem accessing nextcloud 13 server from Webdav Nav.

https:///remote.php/webdav/ ( without “nextcloud” )

did it.