NextcloudPi wizard nowhere to be found after fresh install

Hi there! I just started playing around with NCP today. First two attempts I used Balena Etcher to “burn” the img found on Github. In both cases I could get to the activation screen where the auto generated passwords are. The only way I was able to get to that screen is by using the IP of the Pi (4 in this case). nextcloudpi.local, nextcloudpi.local:4443, and IP:443 did not work in any browser I tried.

After clicking on activate, the browser progress would spin for a bit then end up at the NCP login screen. Now, everything seems to work just poking around the interface, adding a user, changing the password. All of it great. I was even able to sync the Nextcloud apps from Linux, Android, and MacOS without issue. There is an open source handwriting app called Saber that can use Nextcloud to sync with other instances of the app. This will not allow me to login. This app is still in active development, so who knows why it won’t connect? Not me. That said, Saber did work with Nextcloud LinuxServer docker and the AIO Docker. I just found both of those to be a bit heavy for my main server hardware for just a simple sync hub for one app.

Next, I scrubbed the SD card and used Raspberry Pi Imager to write Raspbian Lite (64bit) to the card. I then ran a update/upgrade, and installed curl. Then ran the curl installer.

Again, this went through fine. But the new wrinkle here is that I ended up straight at the login screen rather than ever seeing the activation page. I was able to use the TUI to set a password (since one was not provided in this instance) and log in. But still, no wizard to be found. And it still will not allow Saber to login. Now I want to be clear I doubt that there is anything wrong with NCP itself that is causing the inability to sync Saber, but I do wonder if the fact it is not resolving to the .local domain OR allowing me to run through the wizard and config a domain that way is causing the issue.

I used the TUI to run the reset on the curl install and that did not change behavior. Is there something I’m missing? I confirmed that other .local devices on my network resolve without issue. This macbook I’m writing from is mbp.local and is reachable by other devices on this same network by that name.

Is there any other way to kickstart the wizard? I looked through all the options in ncp-config and nothing sounds like it would do it. Any suggestions of where I could look to maybe hunt this down?

EDIT: Disregard the Saber login issue, there is an option to allow self signed certificates. :slight_smile:

Final Edit:

Not sure what happened, but I flashed the same image to my SD card and started over, this time it worked and I was able to get through the wizard and all is well.