NextcloudPi Update php.ini problem => WebInterface not reachable

Hey folks,

I just updated ncp through SSH to V1.34.7. During the update procces I was notified two times that a php file was changed and gave me 5 Options (similar to this question here: NextCloudPi update to v1.29.8 hangs on new php.ini).

I chose show side by side changes, but the changes were to large to be shown. So I selected option 1, install the package maintainer’s version.

That was obviously pretty dumb, because now I cannot enter the web interface of my NextcloudPi. SSH and samba is still reachable though.

So my question is: Is there anything I can do, to get the web interface working again?

The output of the update process and the output of ncp-report is here: Output ncp-update -

Thanks in advance

hey @IThoughIHadAFreeDay and welcome to the user forums of Nextcloud…

try to sudo ncp-config from commandline and try turning on Web-GUI.
and (re-)set passwords for your NCP-Admin.
Make sure that you try accessing your webgui by https://your.local.ip:4443

BTW: I had a big smile about your nickname. Thanks for brightening my day. And pls remember: if you wanna enjoy a fair day off avoid installing something new :smiley:

Thanks for the quick reply :slight_smile:
I ran sudo ncp-config and web-ui was already activated. I deactivated it and activated it again, but that did not help.
Neither https://my.local.ip:4443 (the site loads endlessly) nor https://my.local.ip works (this one is just blank).

Do you have any other ideas?

PS: Haha thank you. I’ll keep that in mind for my next free days :wink:

I’m sorry for that… maybe @OliverV can be of help here… :pray:

I’d say it is most likely possible to search and find for the original php.ini setting on Github.

Always use the safe route of keeping installed (and working) version, it is what is used by unattended-upgrades, when enabled. NCP users do not ever have run apt update manually, so why did you?

thanks for the reply. I searched the php.ini in this repository (GitHub - nextcloud/nextcloudpi: 📦 Build code for NextcloudPi: Raspberry Pi, Odroid, Rock64, Docker, curl installer...) but there is no php.ini. Should I search in another repository?

And yes, yor’re right, that’s what I’ll do in the future. I have unattended-upgrades enabled but when I connected to my server via ssh and it said, that NCP is outdated and I should run sudo ncp-update, so that’s what I did.

I pastebined content of my rpi2b+ 's
If want to compare, that’s some 1611 lines of code and coments :sweat_smile:

Thanks, thats perfect, I’ll try it out. But the pastbin is private (Error: “Error, this is a private paste or is pending moderation. If this paste belongs to you, please login to Pastebin to view it.”)

Oh. might be they are checking the file for malware…?
I now changed it from public to unlisted, maybe that helps.

Unfortunately not. Could you send me the ini.file via Mail ( That’d be highly appreciated, thank you :slight_smile:

Send uou PM with download link :wink:

Thank you, the download worked! So I found out that there were two files in /etc/php/7.3/fpm/

  • php.ini and
  • php.ini.ucf.old
    The second file was obviously a backup file. I compared it with your file and the only differences were the path to the external hdd (upload_tmp_dir and sys_tmp_dir).

So I overwrote php.ini (the new file from the installation) with the backup file. Then I rebooted my RasPI and deactivated web ui and activated it again through ssh.
Unfortunately, the web ui is still unreachable, although the php.ini files should be correct now.

Is there anything else that I could do?

Now I can reach the admin web ui under https://my.ip:4443. Unfortunately the Nextcloud Web UI is still unreachable (https://my.ip). I updated Nextcloud to 18.x yesterday. Could there went something wrong?

Update 2:
I ran nc-update-nextcloud but it failed. Here are the logs: Nextcloud Update Log -

Last Update: I had to run sudo -u www-data php occ upgrade. It ran successfuly and then I could finally reach my web ui again! :slight_smile:

Thank you very much folks, you saved my weekend!

1 Like