Nextcloudpi: Unable to turn on snapshots "/ is not in a BTRFS filesystem"

I’m trying to enable snapshots on my Nextcloudpi instance, but whenever I try to run either nc-snapshot or nc-snapshot-auto I get the error / is not in a BTRFS filesystem.

From my nextcloudpi system info I have the following:

datadir /media/ncprimary/ncdata
data in SD yes
data filesystem ext2/ext3
data disk usage 5.1G/118G
rootfs usage 5.1G/118G
swapfile /var/swap
dbdir /media/ncprimary/ncdatabase

Both datadir and dbdir are on a BTRFS USB drive, although I notice data in SD is marked yes above.

How can I enable BTRFS snapshots?

Where are you storing those snapshots? Seems you’re not mounted the root volume.

The datadir is in /media/ncprimary where /media/ncprimary is the mount point for a btrfs formatted drive.

I was eventually able to get this working by doing a fresh install and using the btrfs formatting tool in ncp-config, rather than formatting the drive using gparted.

I’m now trying to get those snapshots to sync onto a backup HDD. No luck so far, but I’ll see if it syncs tonight.

Ok. I don’t know how that tool sets it up. However normally you would have something like


Where volume is home, root, media, usr, and so on. These are called subvolumes and you can only make a snapshot of a subvolume and not the root. On some distributions they use @ or .snapshots. Btrfs itself has no default naming scheme