Nextcloudpi stopped working after update (probably PHP or redist server related)

Hi Guys!

I would like to ask you for help.
I’m using nextcloudpi with OdroidHC (the 2.5" hdd version).
After update -i assume- some kind of update the NEXTCLOUD stopped to work, It does not connect to the desktop app, and not accessabel through webbrowser either.

I tried to run, distro upgrade, just plain update and I think, every other possible update.
Firstly the distro update faild…then I used some commands regarding php and i think the buster is installed.

But the graphic UI still not running and the cloud is not accessible.

when I write the IP into browser I get this error:
"Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log."

I figured out the problem is somwhere between PHP and a thing called redist-server

I have tried to reinstall redist, but i got an error:

root@nextcloudpi:~# sudo apt-get install --reinstall redis-server
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/78.4 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database … 43785 files and directories currently installed.)
Preparing to unpack …/redis-server_5%3a5.0.3-4+deb10u1_armhf.deb …
Unpacking redis-server (5:5.0.3-4+deb10u1) over (5:5.0.3-4+deb10u1) …
Setting up redis-server (5:5.0.3-4+deb10u1) …
Job for redis-server.service failed because the control process exited with error code.
See “systemctl status redis-server.service” and “journalctl -xe” for details.
Processing triggers for man-db (2.8.5-2) …
Processing triggers for systemd (241-5) …
You have new mail in /var/mail/root

if you want some log data from me I will gladly provide, but please give the whole path, because im totally noob in these linux things.

If nothing else works I would totally reinstall the whole thing, but I would like to keep the user data and settings on the drive… is this an option?