Nextcloudpi Reboot command shuts down HC4?


downloaded the current nextcloudpi image for odroidHC4 (

Everything went smooth until the first reboot. The odroids IP went offline, and didn’t come back.
After realizing, the odroids LEDs went off, I did a cold reboot (pulling power cord), expecting it to be a one-time problem.
Loggin into panel work, could make some more changes, finally did another “reboot” by using the powerbutton in the panel and choosing “reboot”. Same result as above, IP went off, didn’t come back, LEDs of the device stayed off. Only cold boot brought the device back online.

The power button “shutdown” shuts down the device (I was hoping just the buttons were swapped), but since the reboot during the setup was actually a shutdown, I didn’t really expect that…

Haven’t checked Nextcloupi on other hardware, yet.

Is the any chance, to get that fixed, or solved?

Thanks // Frank

I’ve checked on a Raspberry Pi 400:
no problem here
so it seems to be odroidHC4 related. it’s reproducable on to 2 diffent devices / 2 different installations - so not a hardware fault either

even reboot, shutdown -r and shutdown --reboot make the device being shut down.
is this a Debian 11 bug?

( lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 11 (bullseye)
Release: 11
Codename: bullseye)

after some more tests, it seems to be related to Debian Bullseye
(Ubuntu 22 reboots, Debian 10 reboots)

even more tests:
upgraded Buster to Bullseye → reboots fine
Installed Bullseye via PetitBoot → reboots fine

Currently installing NextcloudPi via curl command… but I don’t expect that to change the boot behavior - will report if it does anyway…

final conclusion:
the Debian Bullseye based NextclouPi image is faulty.

Just realized 1.49.1 is out.

tested, but problem is still not solved.

(btw does anyone but me read this or have used NCP on HC4 and is facing the same problem??)

Unfortunately I have no device to test this. But I follow up your issue as good as possible.

Seems to work now…
not 100% sure what made the device working correctly with old NextcloudPi Image 07-25-22 as well as 1.49.1

I’ve tried several kernel versions, with no success. Also got a bit impationed, and expected the reboot test to be failing when the red and blue LED from the HC4 turned off.

However, at one step I waited a couple of seconds longer and suddenly (as said, not 100% sure what made this happen) the device rebootet.

I guess the solution was this one:

(armbian-config —> System → Install → Install/Update the bootloader on SPI/Flash)

Hope this helps anyone having the same issues…

1 Like

Hi FraZon,

unfortunately this method doesn’t work for me.
I initially removed Petit Bootloader and set up NCP. This was back in March. Since then I was looking for a solution to get the reboot-command working. But even after following the steps described above (armbian-config —> System → Install → Install/Update the bootloader on SPI/Flash) it’s not working…

I’m running Armbian 22.08.8 Bullseye with Linux 5.10.147-meson64.

I’m on the latest NextcloudPi image (currently 1.50.3? from Releases · nextcloud/nextcloudpi · GitHub)

this version is missing install in armbian-config → system
so I’m wondering, how you achieved the SPI update

In latest Version of NCP it’s been moved to nand-sata-install → Install/Update the bootloader on SPI/Flash

as stated above, this is NOT an NextCloudPi issue, but an odroid/armbian one.