NextcloudPI on VM - no access - problem with port forwarding?


#1

Hello,

I am trying to setup NCP as a virtual machine, hosted by an instance of Opensuse Leap 15.

I installed the preconfigured image using Virtual Machine Manager and QEMU/KVM. The system starts up just fine.

In network settings of VMM, I chose as source: eth0 macvtap in bridge mode. The VM appears on the local network, and I assigned a fixes IP.

In the router (Fritzbox) I opened ports 443,4443,80 to both host and guest machine. However, if I run a test like this, it says the ports are closed. Also, I have not been able to access the WebUI (it’s activated).

Can anyone take a guess what I might have missed? I am quite frustrated (bought a Raspi and all accessories brand new yesterday, but booting NCP didn’t work, according to @nachoparker it is probably hardware related). I have not yet managed to see a NC interface once!

Thx!


#2

do you have access from your PC into the VM? this looks just like an issue configuring the virtual image networking

I had it working with these steps

https://ownyourbits.com/2018/10/25/introducing-the-nextcloudpi-vm/


#3

Hey nacho, thx for your support.

I can neither ping my PC from the VM, nor the other way round. I assume that is a result of the bridge mode.

When I try to open https://“ip of vm”:443 from the PC, I get ERR_ADDRESS_UNREACHABLE.

I pretty much followed the linked description to set up the VM, but there is no info on networking stuff in there, so I am basically guessing around.