NextcloudPi on Synology

Hi all.

Is anyone currently running NCP in a docker container on Synology?
My experience in the past is it doesn’t work but I couldn’t see an obvious reason.

I’ve not tried containers on Synology (yet).

What procedure did you follow? (link)
If you could try to repeat last experience, report with logs here…someone might be able to help…

Otherwise, maybe can give the new LXD image a try:
https://ownyourbits.com/downloads/NextCloudPi_LXD_10-08-21/

The Index of /downloads/NextCloudPi_VM_11-08-21/ works on Proxmox for me and at least 1 other user I know of.

Thanks for taking the time to reply, I don’t think Synology supports LXD so I am just trying the NCP docker container fresh.

This is the log:

This is the folder on the Synology:

I created specifically for it, I would assume a permission issue if it wasn’t able to create the other folders?

You’re welcome.
Yes, it looks like permissions/ownership issue. Owner should be www-data

I’d look at /var/log/ncp.log inside container.
can run ncp-config inside the container and run nc-fix-permissions and nc-info and for more details run ncp-report.
Thanks for sharing, in future please use a pastebin service or save to txt file to share logs here.
One can copy/paste plain text and it is searchable, content of screenshots is not.
Or in other words: try to make helping you easier.

Try executing with extended privileges.
The ncp docker image works fine on my Synology, just did a test run, I was curious about how docker was implemented by them. Pretty :sunglasses:

Running nc-info
Gathering information…
NextCloudPi version v1.40.4
NextCloudPi image NextCloudPi_docker_10-07-21
distribution Debian GNU/Linux 10 \n \l
automount no
USB devices usb1 synoboot
datadir /data/nextcloud/data
data in SD yes
data filesystem btrfs
data disk usage 469G/7.9T
rootfs usage 469G/7.9T
swapfile /dev/zram3
dbdir /data/database
Nextcloud check ok
Nextcloud version 21.0.4.1
HTTPD service up
PHP service up
MariaDB service up
Redis service up
HPB service down
Postfix service up
internet check ok
port check 80 open
port check 443 open
IP 172.17.0.2
gateway 172.17.0.1
interface eth0
certificates none
NAT loopback no

At me, its running directly without docker, NC 22.2 on Synology DSM 7

Did you create this as a user on your Synology? I ran it with high privilege but this didn’t fix anything.

The user is the one I use to login to DSM (v7)

Maybe can check How do I debug and fix common Docker container issues? - Synology Knowledge Center and use their forum to get help. As It doesn’t seem to be NCP or NC related.