NextcloudPi on Raspberry Pi - just isn't working

ncp
#1

Having not used my Nextcloud for a few months, I decided to get it going again on my Pi. And figuring that it being at least 6 months old I’d be better off just downloading the new version, burning to SD and booting up. No joy!

I did get to the Activation page finally. I had to disregard the documentation which told me to go to https://<<address>:4443 - just get no connection there, so tried https://<address> and only then get the Activation page.

That then took me to the NCP Panel. Tried the wizard - nothing happened. Tried the options all down the left hand side - ssh, LetsEncrypt etc - nothing happened.

So I decided to reburn the SD, just in case. Booted up the Pi again - and exactly the same thing.

What has happened? NextcloudPi was a brilliant system six months ago - is it all broken now?

1 Like
#2

Hi
Thanks for reporting.
Fact is: documentation is not always up to date with latest developments.
(please include link, so someone can do something about it, when they so feel inlined :wink: )
First run is always a bit of a long wait…which image and model Pi are you using?
And yes, you should be redirected to :4443 after activation.
It will not be available before activation.
ssh letencrypt etc nothing happend!? No output at all? Checked the logs?
Works fine here!

#3

I can verify that the latest NCP image for the Pi works perfectly well

#4

Hello,

same here. Raspberry Pi Model B+ v1.2, NextCloudPi installed on a fresh 8GB microSD card, no external devices connected. After a while the admin panel opens, but i can only see a perpetual spinner; some links work (like OP mentioned - the wizard, shutdown menu, current config), but I’m unable to go anywhere further.

I tried to upgrade NextCloud to the latest version; the upgrade was successful, but when I ran ncp-update-nc from the command line, I got a “Malformed version” error.

#5

Hi @Cosi
Which image did you use?

#6

Hello @OliverV ,

I used the snapshot from 23rd October (NextCloudPi_RPi_10-23-18).

#7

Try running ncp-update again (latest is v0.66.1 at present date & time)
If not fixed by that, you could try latest image.
NextCloudPi_RPi_11-04-18
Should fix any known ncp update issues.

[quote=“Cosi, post:4, topic:40137”]
perpetual spinner
[/quote] That could be a bad power supply or power cable :tired_face:
What is output of dmesg?

2 Likes
#8

Thanks for the advice!

Yeah, I guess my power supply is too weak. When I ran ncp-update, after a long while I got this error message:

E: Sub-process dpkg --set-selections received signal 4.
E: Couldn't record the approved state changes as dpkg selection states
/usr/local/bin/ncp-update: line 43:  3622 Illegal instruction     grep -qP "v\d+\.\d+\.\d+" <<< "$VER"
NextCloudPi updated to version 

and now my Pi seems to be dead (can’t log in using SSH, so I don’t know what’s wrong). I’ll try to download the latest image, but first of all I’ll buy a new power supply :smiley:

#9

Update:
After getting a better power supply, installing NCP from the latest snapshot and running sudo ncp-update, I got this error message again:

Installing nc-restore
/usr/local/bin/ncc: line 2:  3298 Illegal instruction     sudo -u www-data php /var/www/nextcloud/occ "$@"
/usr/local/bin/ncc: line 2:  3307 Illegal instruction     sudo -u www-data php /var/www/nextcloud/occ "$@"
/usr/local/bin/ncc: line 2:  3337 Illegal instruction     sudo -u www-data php /var/www/nextcloud/occ "$@"
/usr/local/bin/ncc: line 2:  3347 Illegal instruction     sudo -u www-data php /var/www/nextcloud/occ "$@"

(...)

E: Sub-process /usr/bin/dpkg exited unexpectedly
/usr/local/bin/ncp-update: line 43:  5121 Illegal instruction     grep -qP "v\d+\.\d+\.\d+" <<< "$VER"
NextCloudPi updated to version 

https://nextcloudpi.local:4443 doesn’t respond at all.

#10

Would it be better if I jumped onto IRC? Should I also start a new thread for this? I really would just like to get something working.

I also have a problem getting the “NextCloudPi_RPi_Berryboot_11-04-18.img” or the “NextCloudPi_RPi_Berryboot_10-23-18.img” to work at all. I have been trying for the past week or more on the first image. As a new image has been generated I put my info from it at the bottom with a History tag. For both I am using the “berryboot-20180929-pi2-pi3” (the latest?) if that matters.

Starting here–>
The NextCloudPi_RPi_Berryboot_11-04-18.img breaks after upgrading to latest. The software installs with only one error about extending the file system now. At the first prompt after install you are prompted to upgrade with via command line or using ncp-config. This upgrade seems to go ok and the “first run/Setup” webpage is displayed on going to the IP or IP:4443. On that page the ncp auto-generated passwords are generated and a button to click “Activate” is shown. When you click the Activate you get a never ending “loading” spinning task. At this point there seems to be no way to get into the system. Some troubleshooting I have done is below but feel free to ignore. I have no problem starting over from scratch as needed to get this working just once.

I have tried setting nc-passwd manually and then enabling the web console both with ncp-setup, This then yeilds a logon pop up (normally the ncp user for 4443) the password auto generated or the one I manually set DOES NOT work here. I have also nc-fix-permissions, and the nc-init to no success as well.

History if wanted:
The “NextCloudPi_RPi_10-23-18.img” software loaded as expected with two errors at boot. First is the error about extending the file system (found the fix to disable this), and the second a Zram error. I was unable to fix the Zram problems not matter how many options or suggestions I tried.

Once NextCloudPi_RPi_10-23-18.img was all “stable” I then ran the updates to the latest versions using either the webpage or ncp-config and that is when things stop working. You get a connection refused on the webpage and various errors in the logs. I don’t have these logs anymore and now there is a new image so doubt any of that is useful now. But everything looked good and working until a update to this image was done as well. I do not know if the two are related at all but but stop working after installing then updating.

#11

FWIW, to me it looks like some package(s), at least php, have been compiled recently using options / instruction set(s), that are not supported on the ARM chip on older Raspi. Here is what I’m seeing:

  • I’ve downloaded https://ownyourbits.com/downloads/NextCloudPi_RPi_11-04-18/NextCloudPi_RPi_11-04-18.torrent and flashed onto a fresh empty 4GB SD Card.
  • Booted my raspi, but https://nextcloudpi.local/ just shows “The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.”
  • Logging in via ssh, I see “Illegal instruction” returned by root@nextcloudpi:/var/log/apache2# php --version
  • I performed a “sudo ncp-update” , which ran smoothly except that it printed again “Illegal instruction” close to the end, likely caused by the “grep … $VERSION”
  • Now, after the udpate, the situation is worse: even “grep” and “ls” return “Illegal instruction” now.

My raspi seems to be an old Model B rev 2:
cat /proc/cpuinfo

processor : 0
model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 697.95
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7
Hardware : BCM2835
Revision : 000f
Serial : 00000000303dca44

Maybe also relevant:
root@nextcloudpi:/var/log/apache2# ldd /bin/ls

/usr/lib/arm-linux-gnueabihf/libarmmem.so (0xb6edd000)
libselinux.so.1 => /lib/arm-linux-gnueabihf/libselinux.so.1 (0xb6eaa000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6d6b000)
/lib/ld-linux-armhf.so.3 (0xb6ef3000)
libpcre.so.3 => /lib/arm-linux-gnueabihf/libpcre.so.3 (0xb6d0c000)
libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0xb6cf9000)
libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb6cd0000)

root@nextcloudpi:/var/log/apache2# file /bin/ls
/bin/ls: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 3.2.0, BuildID[sha1]=c24d547f9d1a35be487f168d83c3cbfcebeaa39c, stripped

1 Like
#12

Turns out that https://ownyourbits.com/downloads/NextCloudPi_RPi_10-23-18/ seems to work, but on my old Raspi Model B with just 512MB it is so slow that it’s not really usable. I’m wondering what is considered the minimum meaningful hardware configuration for Nextcloudpi to work well?

#13

Can confirm, same issue here. I was thinking it was network related but given it some thought, it’s the PI i suppose. I dont mean to hijack it, but am running the Elemental Pi with Next cloud installed on an SD card following the official instructions. Other than that, i did not touch a single thing in the CLI. What are some things I could type to begin debugging? Thank you.

#14

Alright I got it working!

First thing is first. Apply the appropriate image to your hardware.
Get in the Terminal. run “sudo ncp-update”, let it update then reboot with “sudo reboot”
Boot back in and run “sudo ncp-config”, the config should have way more options than on a fresh install Nextcloud with out its’ updates.

Look for NC-webui, it should have an asterisk in the list. Get into that and type in Yes where “no” is. Pretty straight forward.

THen accessing it on the web gui, make sure you use the Nextcloud user password given in the activation page. (not the NextCloudPi, i dont know why yet), and you should be good to go.
If you still cant login, verify the password by looking for the “nc-admin” option in the list on your NC device.

that should verify your password.

#15

The comments on https://ownyourbits.com/2017/02/13/nextcloud-ready-raspberry-pi-image/ says “Let us know, if this works on the Raspberry PI 1”. The answer is no, it doesn’t work. As mober noted above, running the install script leads to “ls” returning “Illegal instruction”. This is because the PCRE library is apparently compiled with flags that are incompatible with RPI1, and ls links to libpcre.

RPI1 is armv6, RPI2 is armv7 so I guess the problem is the -march=armv7-a flag. Could someone update the packages installed by that install.sh script to be built for armv6 instead of armv7?

Either that or announce that RPI1 support is dead, so people don’t waste half a day setting up the wrong thing. And now the whole OS is broken, can’t reinstall the right libpcre3 because “dkpg” says Illegal instruction. Can’t even scp it from another machine after extraction from a deb file, because ssh is broken too.

I don’t even understand why the pcre and php from debian aren’t good enough? Why does the install script want to change those? Just install nextcloud on top of the standard packages…

#16

Arm6 is no longer supported in docs

#17

OK, I see. What’s confusing is:

  1. https://ownyourbits.com/nextcloudpi/
    which says “Install it in any Debian supported architecture in one line”
    (OK, re-reading, I guess I missed that the word ‘supported’ meant there are restrictions…)

  2. the comments on the blog which says “it should work, try it” (and since the comments are closed, no way to reply to that…)

  3. the links on https://ownyourbits.com/nextcloudpi/ point to https://github.com/nextcloud/nextcloudpi/wiki which says “not here any longer”

  4. I never ended up at https://docs.nextcloudpi.com/en/should-i-use-a-raspberry-pi/, it would be a good idea to add a link to that page from that nextcloudpi page.

#18

Dont know where you see that?
https://github.com/nextcloud/nextcloudpi/wiki has a link to docs and says :

The documentation has been moved to docs.nextcloudpi.com.

NCP’s Documentation, is a work in progress, and maintained by (a very few) volunteers.
If you wish to contribute, please create account at docs.nextcloudpi.com and join our Telegram Wiki Team Thanks :wink:

#19

Yes that’s what I mean by “no here any longer”, it moved elsewhere - which means instead of the expected “how to install” page (given the URL) we land on a FAQ that starts with " Two Factor Authentication for Nextcloud", quite advanced for a first time user, so I went back looking for more basic help :slight_smile:

If it was just a wiki page I’d indeed create a login and fix it, but ownyourbits.com sounds like something hosted outside of nextcloud.com or nexcloudpi.com, right? That’s the page that needs fixing most, IMHO. And I think I’m still way too confused to contribute something useful, other than relating my impressions as a first time user.

#20

Ah, this is WordPress, not Wiki, despite the team name :slight_smile: … I created an account in order to reorder https://docs.nextcloudpi.com/en/, in order to have Getting Started at the top, at least, but that needs permissions to edit the page. I don’t have Telegram set up. An actual wiki would have been simpler :slight_smile: