NextcloudPI Odroid Update from 1.18.0 to 1.19.1 aborts

Hi,
I am trying to update from 1.18.0 to 1.19.1. Unfortunately the update breaks with the message “/usr/local/etc/library.sh: line 130: echo: write error: No space left on device”
Unfortunately my knowledge of Linux is not good.

df prints the following. What can I delete from the LOGS?
Or can I enlarge the partition?

Filesystem 1K-blocks Used Available Use% Mounted on
udev 953608 0 953608 0% /dev
tmpfs 204488 22312 182176 11% /run
/dev/mmcblk1p1 15158576 3997372 10970572 27% /
tmpfs 1022424 0 1022424 0% /dev/shm
tmpfs 5120 4 5116 1% /run/lock
tmpfs 1022424 0 1022424 0% /sys/fs/cgroup
tmpfs 1022424 0 1022424 0% /tmp
/dev/zram0 49584 48560 0 100% /var/log
/dev/sda1 3906967324 1777331160 2127747560 46% /media/myCloudDrive
tmpfs 204484 0 204484 0% /run/user/1001

What can I do to fix the error?

I’d try turn on nc-ramlogs from:
ncp-web or ncp-config >SYSTEM>nc-ramlogs

also check and look for logs which are filling up /var/log/

Thanks for the information.
I have changed the logs to RAM. It’s the same problem.
How can I find out what is filling up the logs?

Which logs can I possibly delete
ls -l
total 35020
-rw-r–r-- 1 root root 0 Oct 10 07:00 alternatives.log
drwxr-x— 2 root adm 4096 Mar 26 2019 apache2
drwxr-xr-x 2 root root 4096 Oct 10 06:58 apt
-rw-r–r-- 1 root root 135168 Dec 25 09:37 armbian-hardware-monitor.log
-rw-r----- 1 root adm 1236992 Dec 25 09:40 auth.log
-rw------- 1 root utmp 4096 Dec 10 20:45 btmp
-rw-r----- 1 root adm 827392 Dec 25 09:40 daemon.log
-rw-r----- 1 root adm 8192 Dec 25 09:37 debug
-rw-r–r-- 1 root root 12288 Oct 10 07:00 dpkg.log
-rw------- 1 root root 12288 Dec 25 09:38 fail2ban.log
-rw-r----- 1 root adm 5660672 Dec 25 09:40 kern.log
drwx------ 2 root root 4096 Dec 25 05:54 letsencrypt
-rw-r----- 1 root adm 7393280 Dec 25 09:37 mail.info
-rw-r----- 1 root adm 962560 Dec 25 09:37 mail.log
-rw-r----- 1 root adm 500 Dec 25 09:37 mail.warn
-rw-r----- 1 root adm 5681152 Dec 25 09:40 messages
drwxr-s— 2 mysql adm 4096 Mar 25 2019 mysql
-rw-r----- 1 root www-data 24576 Dec 25 09:39 ncp.log
drwxr-xr-x 2 ntp ntp 4096 Feb 15 2018 ntpstats
-rw------- 1 root root 2541 Dec 25 09:37 php7.2-fpm.log
drwxr-x— 2 redis redis 4096 Mar 9 2019 redis
drwxr-x— 3 root adm 4096 Dec 11 16:27 samba
-rw-r----- 1 root adm 8241152 Dec 25 09:40 syslog
drwxr-xr-x 2 root root 4096 May 25 2017 sysstat
-rw-r----- 1 root adm 5562368 Dec 25 09:40 ufw.log
drwxr-x— 2 root adm 4096 Dec 25 09:37 unattended-upgrades
-rw-r----- 1 root adm 24576 Dec 25 09:37 user.log
drwxr-xr-x 2 root root 4096 Mar 13 2018 wicd
-rw-rw-r-- 1 root utmp 23040 Dec 25 09:38 wtmp

try:

sudo du -h --max-depth=1 /var/log/

and

ls -lhtr /var/log/

also what is output of

free -h

sudo du -h --max-depth=1 /var/log/
12K /var/log/mysql
11M /var/log/apache2
4.0K /var/log/unattended-upgrades
4.0K /var/log/ntpstats
4.0K /var/log/sysstat
4.0K /var/log/wicd
1.2M /var/log/redis
1.9M /var/log/samba
44K /var/log/apt
64K /var/log/letsencrypt
48M /var/log/

ls -lhtr /var/log/
drwxr-xr-x 2 root root 4.0K May 25 2017 sysstat
drwxr-xr-x 2 ntp ntp 4.0K Feb 15 2018 ntpstats
drwxr-xr-x 2 root root 4.0K Mar 13 2018 wicd
drwxr-x— 2 redis redis 4.0K Mar 9 2019 redis
drwxr-s— 2 mysql adm 4.0K Mar 25 2019 mysql
drwxr-x— 2 root adm 4.0K Mar 26 2019 apache2
drwxr-xr-x 2 root root 4.0K Oct 10 06:58 apt
-rw-r–r-- 1 root root 0 Oct 10 07:00 alternatives.log
-rw-r–r-- 1 root root 12K Oct 10 07:00 dpkg.log
-rw------- 1 root utmp 4.0K Dec 10 20:45 btmp
drwxr-x— 3 root adm 4.0K Dec 11 16:27 samba
drwxr-x— 2 root adm 4.0K Dec 25 09:37 unattended-upgrades
-rw-r----- 1 root adm 8.0K Dec 25 09:37 debug
-rw-r----- 1 root adm 24K Dec 25 09:37 user.log
-rw-r–r-- 1 root root 132K Dec 25 09:37 armbian-hardware-monitor.log
-rw-r----- 1 root adm 500 Dec 25 09:37 mail.warn
-rw------- 1 root root 2.5K Dec 25 09:37 php7.2-fpm.log
-rw------- 1 root root 12K Dec 25 09:38 fail2ban.log
-rw-rw-r-- 1 root utmp 23K Dec 25 09:38 wtmp
-rw-r----- 1 root www-data 24K Dec 25 09:39 ncp.log
drwx------ 2 root root 4.0K Dec 25 13:15 letsencrypt
-rw-r----- 1 root adm 940K Dec 25 18:15 mail.log
-rw-r----- 1 root adm 7.1M Dec 25 18:15 mail.info
-rw-r----- 1 root adm 5.4M Dec 25 18:25 ufw.log
-rw-r----- 1 root adm 5.4M Dec 25 18:25 kern.log
-rw-r----- 1 root adm 808K Dec 25 18:25 daemon.log
-rw-r----- 1 root adm 7.9M Dec 25 18:26 syslog
-rw-r----- 1 root adm 5.5M Dec 25 18:26 messages
-rw-r----- 1 root adm 1.2M Dec 25 18:26 auth.log

free -h
total used free shared buff/cache available
Mem: 2.0G 357M 91M 36M 1.5G 1.5G
Swap: 3.0G 2.2M 3.0G

/dev/zram is filled to 100%
Can you run

sudo ncp-report

and share via pastebin or similar.

Report: https://pastebin.com/VEJLf3jy

Maybe try disable log to zram and reboot, looks like its using a swapfile that is too small.

swapfile /var/swap (from ncp-report)

Or create a larger swap file.

I used this https://www.bitpi.co/2015/02/11/how-to-change-raspberry-pis-swapfile-size-on-rasbian/

if I enter the command “free -m” from the link there seems to be enough swap

free -m
              total        used        free      shared  buff/cache   available
Mem:           1996         433         122          42        1440        1460
Swap:          3046           0        3046


sudo nano /etc/dphys-swapfile

# /etc/dphys-swapfile - user settings for dphys-swapfile package
# author Neil Franklin, last modification 2010.05.05
# copyright ETH Zuerich Physics Departement
#   use under either modified/non-advertising BSD or GPL license

# this file is sourced with . so full normal sh syntax applies

# the default settings are added as commented out CONF_*=* lines


# where we want the swapfile to be, this is the default
#CONF_SWAPFILE=/var/swap

# set size to absolute value, leaving empty (default) then uses computed value
#   you most likely don't want this, unless you have an special disk situation
#CONF_SWAPSIZE=

# set size to computed value, this times RAM size, dynamically adapts,
#   guarantees that there is enough swap without wasting disk space on excess
#CONF_SWAPFACTOR=2

# restrict size (computed and absolute!) to maximally this limit
#   can be set to empty for no limit, but beware of filled partitions!
#   this is/was a (outdated?) 32bit kernel limit (in MBytes), do not overrun it
#   but is also sensible on 64bit to prevent filling /var or even / partition
#CONF_MAXSWAP=2048

From your output: 0 of this swap space is being used.
I’ d try disabling dphys-swapfile and nc-ramlogs and manually enable swap.