NextcloudPi no more access

Hello everybody,

I installed a Nextcloudpi on a Raspberry 4 two month ago.
I was a total beginner for command line execution, server installation and such but with a good french tutorial I was able to do the installation easily and use the tool in the past two months to replace my Google habits (agenda, tasks, newsfeed, drive etc).
But yesterday my connection to the server was refused (DNS certificate couldn’t be authenticated) and if I forced the connection I found a page saying that the service was unavailable.
I tried to connect to the server using SSH but my credentials were not accepted. Same thing when connecting the Raspberry Pi to a screen with a keyboard.
My last back up is from 10 days ago so I’d like, if possible, to recover my data instead of reinstalling everything directly. And more important I’d like to understand what went wrong to avoid the problem in the future.
Most answer on this kind of issue I found on this support use command line but I can’t connect with SSH and when I access to the Raspberry Pi directly with a screen and a keyboard I have to login before executing command line and it doesn’t work either.

So I have two questions :

  • Since the installation is done on a Raspberry Pi I have access to the HDD containing the operating system, is it possible to modify the file containing the login and password of the system administrator directly ? I read about the config.php file but from my understanding the ‘dbuser’ and the ‘dbpassword’ are not the credentials used to connect via SSH or directly on the machine. There is also the config.log file but it is hard to find something in it and from my understanding it is more about the users registered in my Nextcloud session.
  • In your opinion could that be a hack ? I thought it could be a simple expiration of my certificate and I may have forgot my pasword since I used it only during the setup of the server a few month ago. But I’m not sure, what can I do to be sure that this wasn’t a hack ?

Thanks in advance for your answers and I’d like to say that I am very gratefull for the development team work.

Check FAQ for password info and how to view or reset.

If you have not created another user or set ssh password the default on RPI is

user pi
pw raspberry

Hello !
Thanks for your reply, following my tutorial the first step was to change the default pwd to avoid easy hack access. Here the tutorial :
I tried also a basic Rpi password reset option

The command : mount –rw –o remount / doesn’t work… but I think it’s because my configuration is set with the basic Rpi install on the SDcard and Nextcloud install on the HDD. I have to find a way to execute the “remount” command in this conditions.

At the prompt type the following command :

mount -o remount, rw /

If this results in an error message such as :

/bin/sh: 0: can’t access tty; job control turned off [ 21.366191] random: crng init done

simply try the mount command again :

mount -o remount, rw /

Finally you can now attempt to change the password :

passwd pi


Hello, I tried this line but I have this result :

I think it is because the Nextcloud system is installed on the HDD but the system is installed on the SD card. In the tutorial I had to modifiy the fstab file to allow this division.

OK problem solved, sort of because I spend a bit of time to test all combinations of username and password to access again to the promp but I figured that my keyboard wasn’t recognized as AZERTY but QWERTY that is why I was unable to login.

I still have a 503 Erro problem but I will open another subject.

Thanks a lot for your help !