[NextcloudPi] Ncp-web multiple authentication requests

ncp

#1

I’ve just updated ncp to v0.31.10, and I’m still getting multiple drop-down requests for authentication for ncp web. It actually makes me enter my credentials 4 times on the first run, then 3 times for subsequent runs. I feel like I’ve seen other people mention this before, but I couldn’t find the postings :frowning:

I’m running OSX Opera as my browser, which doesn’t seem to have a mechanism for saving credentials for the simple HTTP auth dialog, so this is extra inconvenient.

Does anyone know if this a browser configuration issue (I do get similar behavior in FF and Safari), or is this possibly an ncp-web issue?


#2

This issue was fixed, I test it everyday using firefox, so at least with FF it should work. Try with a clean instance without cache


#3

for me it seems to work with 31.11 now - on ff


#4

Okay, thanks for the replies. I’ll give it a whirl and report back.


#5

Still happening, for sure. Here’s what I’ve done so far: I downloaded a fresh image of NCP, and burned it to a USB flash drive, and booted up my RPi. I updated NCP so that I’m now at 0.31.11. I updated Firefox to the latest version (56.0). I cleared out my caches from ALL my browsers (!), then just for good measure, I created a new user account, rebooted my computer, and logged into the new account. I started up Firefox, went to my local NCP instance (https://grumpy.local:4443/) and still was asked 3 times to enter my login credentials. Sometimes on reload, it will only ask once, and sometimes it will ask me as much a 4 times before letting me proceed. I’m certain that I’m entering my password properly (I pasted just to avoid introducing typos).

I am getting the same behavior on Opera, Firefox, and Chrome. I’ll be happy to make and post a screen recording of this behavior if anyone thinks it would be helpful.

Could it have anything to do with the fact that the site is still local, and doesn’t have a security certificate yet?

Here’s what I suspect is happening, although this is really no more than a hunch. I have noticed that each time the login dialog drops down, the ncp-web page is in a different stage of loading. Is it possible that credentials are being requested along with each HTTP request to the web server for the individual components of the page?

Here are screenshots of each of the 3 login requests I’m getting.

1st request:

2nd request:

3rd (and final, on this occasion) request:

I’d love to get to the bottom of this, as it is really surprisingly annoying. :frowning_face:


#6

Jimmy, what behavior are you seeing? Just one request for credentials? And how long is that “valid” for? I’m wondering if you need to login again once you’ve closed the brower, for example.


#7

So am I the only one out there experiencing these symptoms? If that’s the case, then the problem’s gotta be on my end somewhere. Would love to hear if anyone else is experience this.


#8

Yes, I would be interested to know if there are more people seeing this.


#9

i just tried it just now and needed to fill in the credentials TWO times. but i’m not quite sure if i was mistyping the pw on try 1. can tell you more on like tomorrow


#10

Hi,

Password authentication was rewritten and improved. The issue should be completely gone after an update.

Please, report otherwise

Thanks


#11

@nachoparker You did it! All the authentication issues are fixed!! Hooray! (not that I ever doubted you, of course)

Good to know that I wasn’t imagining this after all. :slight_smile:

(sorry for the late reply, I’ve been away for a bit)


#12

hahaha no, you were not crazy :stuck_out_tongue:

thanks for reporting!


#13

You definitely deserve a nice chocolate-frosted donut for that.


#14

Im still seeing it to this day. I can not get in to ncp-web login i have tried with firefox and chrome with cleared cache. It will always reload the login windows no matter what i write on it. (im using keepass so the password really is correct) The password is the same as what I use to login to my raspberrypi Root with ssh right?


#15

hi,

the username/password is ncp/ownyourbits. It’s in the docs and the wiki