[NextcloudPi] NC-web login failing after upgrade to v30.0

hey there @nachoparker

i just upgraded to ncp-web v30.0 and now - for the first time - i’m being asked to enter a user and passwd. so i tried all the users i could imagine but none worked. could the problem arise from my pw itself since it contains a special character (@)? and thus would be related to https://github.com/nextcloud/nextcloudpi/issues/155

or which user is ncp-web waiting for exactly?

1 Like


Yes, this info was updated on the wiki, and I will also announce it in the next release (soon). The username is pi and the password is whatever your pi password is in the RPi.

We needed more security in ncp-web

1 Like

i tried pi and the referring password… but failed. must be b/c of special characters in pw.

that sounds a bit weird to me. Can you try temporarily changing the password for user pi through SSH?

sudo passwd pi

it IS apparently about the special character mentioned above. since i changed it and it worked

first problem :S

can we know what character it is?

yes, of course… see below

it’s the at-sign itself. (well it WAS since i had to change it) :wink:

though i need to re-enter my credentials between 4 and 5 times before being able to use ncp-web. is there any chance to put that into a temp. cookie?

Noob here. I have the same problem. I had a generated admin pasword and it lets me in fine to nextcloud but not to ncp-web v30.0. But i didint understand from your conversation what password shoud i use?

I tried the admin/ownyourbits and the one wich i changed it to. and i tried to change it back to admin/ownyourbits
and the raspberry pasword and the one i changed it to. nothing worked? help

have you changed your pi SSH password? if not then user is pi, password raspberry

I got a report of that issue already, it seems that some people need to input the password several times in order to load the website completely

Ahhhhh…this was driving me NUTS until I found this thread (and read it carefully). I would have to say that this information (about logging in to the web interface) is non-obvious, especially to anyone who’s been using NCP previously (this change has not been mentioned prominently anywhere, so I was assuming I had done something wrong (usually a safe assumption)). Even knowing what I was looking for, I had a tough time finding it in the wiki. Because this issue arises immediately to anyone trying to use the web interface, I’d like to suggest at least mentioning this on the download page:
and certainly in the changelogs/release announcements.

You are right. Will do.

It was on the wiki and the changelog ( v0.29.3 ), but it’s true, a bit hard to find. I also created an issue on github for people looking for this

It was a high priority to have some extra protection for ncp-web because of how powerful it is.