NextcloudPi: HPB-Service down after dist-upgrade

Hi all,

after a dist-upgrade of my raspberrypi several things broke in my nextcloudpi instance. I could fixed all but the HPB-Service.
I tried to solve it with the help of this discussion: error with trusted_domain after upgrade · Issue #1332 · nextcloud/nextcloudpi · GitHub but it didn’t work for me.
After cleaning the config.php and using these commands:

source /usr/local/etc/
set -x
set-nc-domain <your_domain>

I get this output:

✓ redis is configured
🗴 push server is not receiving redis messages (received 741505944, got 0)

The command ncc notify_push:self-test says this:

+ ncc notify_push:self-test
🗴 no push server configured

I googled for hours, but didn’t find another solution, so can someone please help me with this problem?

Some further informations:
NCP System Info:

NextCloudPi version  v1.49.0
OS                   Debian GNU/Linux 11. 5.15.32-v8+ (aarch64)
automount            no
USB devices          sda 
datadir              /media/myCloudDrive/ncdata
data in SD           no
data filesystem      btrfs
data disk usage      967G/1.9T
rootfs usage         9.1G/59G
swapfile             /var/swap
dbdir                /var/lib/mysql
Nextcloud check      ok
Nextcloud version
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
HPB service          down
Postfix service      up
Internet check       ok
public IPv4          ****
public IPv6          ****
Port check 80        closed
Port check 443       open (ipv4)
IP                   ****
Gateway              ****
Interface            eth0
certificates         none
NAT loopback         no
Uptime               16:17

I don’t use letsencrypt, instead I use the ssl-certficate of my domain-provider.
HPB-Service was also down with older Nextcloud- and NextcloudPi-versions, I just tried to solve the problem with updates.
After updating to Nextcloud version 24.0.4 I got this message:

Disabled incompatible app: notify_push

I use apache2 as my webserver.

Did you reboot your system already?
There where some remarks about HPB down which vanished after a reboot.

Yes, I rebooted after executing the described commands.

I edited some more informations about my configuration. I hope it can help to solve the problem. Thank you!

Still have the problem. May someone be able to help with this? I don’t know what I can do anymore to solve this.

I don’t know but we can try and see if we can find out what the issue is

Can you run ncp-report in the terminal and post the output?

I also found a related issue with this on GitHub, if you haven’t seen it yet. There are a couple troubleshooting steps mentioned by the people in the issue and logs to check and commands to run for checks :slight_smile:

Edit: Also, here’s the manual for the push installation

And another topic on the forum

Thanks for the help! I got the solution now because of a combination of your links and googling.
This was what I had to do:

  • Start the redis-server
  • Setup Redis
sudo ncc notify_push:setup
  • Make sure the proxy-modules are enabled
sudo a2enmod proxy
sudo a2enmod proxy_http
sudo a2enmod proxy_wstunnel
  • Edit the nextcloud.conf in your /etc/apache2/sites-available - directory.
sudo vi /etc/apache2/sites-available/nextcloud.conf
  • Add the following lines:
ProxyPass /push/ws ws://
ProxyPass /push/
ProxyPassReverse /push/
  • Save and reload Apache2
sudo systemctl restart apache2
  • Configure your Nextcloud-domain with redis
sudo ncc notify_push:setup https://<your_domain>/push

Now it should work for you if you have the same problem. I think the problem was that the dist-upgrade caused some errors that I had to solve on my own. And while creating the nextcloud.conf for apache2 I forgot the lines for the redis-server.
Thanks for the help @ZendaiOwl !

1 Like