NextcloudPi - External access (theoretically) not working (ports closed)


I’ve recently installed NextcloudPi natively (without docker) on my raspberry and configured it for external access (freeDNS and letsencrypt are configured properly).

However, I do not want it to be accessible via the standard port (443) which is why I’ve changed the external port in my router (fritzbox) to another value (say 405).
As soon as I change the port to 405 in my router and restart my raspberry, Nextcloud system info tells me that the ports are closed and it has no working internet connection: features like installing new apps do not work BUT practically I can STILL REACH my cloud via my DynDNS and the changed port (405) in my browser WITHOUT PROBLEMS:

When I change the external port in my router back to standard (443) and restart next cloud, everything’s working fine.

Do I really have to keep the ports at this standard value (443) or what might be the problem.

I’m not particularly good at this, and might just embarrass myself by replying.

Don’t you have to change the port settings in your ncp server i.e. apache to make this work?
In other words:
You can’t just open any port in the router, without also making ncp (apache) answer to that particular port, no?

or I’m I getting this wrong? :sweat_smile:

The pannel actually checks port 80 and 443 because letzencrypt needs them for renewing the certificate every 90 days. If the server does nog answer on these ports the renewal will fail and you have to manually forward them to the server every 90 days and renew the certificate, or your certificate will expire.

No, I’ve changed EXTERNAL ports in my router (port forwarding) and actually it works but only I reboot

There is nothing wrong with lensencrypt since it is working but as soon as I reboot, connection fails. Consequently I assume the issue has something to do with a procedure which runs each time I boot up my system