Nextcloudpi does not detect ethernet

Recently, my ISP decided to change their router however the range of the internal ip address in the new router is different from the old one, and my ncp was set with a static IP. Because of this, i for some reason decided that the best oprion is to just change the Nextcloudpi’s internal IP Address, i first tried to set it to dynamic first, thinking i would just stick to whatever it gives me, but for some reason, even after reboot, it doesn’t give me a new IP. Then i tried setting it manually, putting it with 192.168.0
134, and what a shocker, it didn’t change even after reboot. I then tried to turn static ip off again, and then clearing the ip address space. This is where things go south, because after this, it decided to not give me any ip address. At first i though that it was just a glitch and assigning an ip using

sudo ip addr add dev eth0

But, after i reboot, it didnt work. Then i decided to try pinging yahoo, it did not find it. Right now i have no idea what i am supposed to do, can anyone help? Or are there any way to reset just my network settings on nextcloudpi? Thanks in advance!

Not my cup of tea but you should try

Nevermind, i have no idea what i did, but after turning on wifi, and then connecting to my wifi, for some reason, the ethernet got detected again. I have no idea what the logic about that is, but it works.

1 Like