NextCloudPi Config Wizard stops at "letsencrypt" with certbot error

Hi Everyone, I’m installing NextCloudPi for the first time on a Raspberry Pi 4 4gb with a fresh install of raspbian lite. Everything seems to be going okay but when I try to set up the DDNS it freezes at ‘letsencrypt’ and pops up the following error:

Certbot can obtain and install HTTPS/TLS/SSL certificates.  By default,
it will attempt to use a webserver both for obtaining and installing the
certificate. 
certbot: error: argument -m/--email: expected one argument

Thanks for any help!

I got the same issue, took a while to track down, but it looks like in the config file deep in the code, the email just isn’t being set, so it sees other -params as arguments and gets mad. if you do “sudo nano /usr/local/etc/ncp-config.d/letsencrypt.cfg” and head over to the last section of that long single line, you’ll see the text “{“id":“EMAIL”,“name”:“Email”,“value”:"",“suggest”:"mycloud@ownyourbits.com”}” fill the “” after “value:” with “your@email.com” and try again. this fixed my problem!

5 Likes

Man, I had the same problem, your solution worked as a charm, I was literally screaming with joy, when it came through. Thanks.

Thank you verry much. I had the same problem and tried it hours before i found this answer. Worked for me :+1:

Thank you very much! Worked very well and finally solved my problem :)!

How is a normal person ever going to find that out?