Nextcloudpi Backup

Guten Morgen,

ich habe am Raspberry Nextcloudpi am laufen.

Da man auf der ncp WeboberflĂ€che ein Backup erstellen kann, möchte ich das nun auch machen. Als Backup habe ich einen USB Stick genommen, diesen schließe ich an.
Sobald ich diesen angeschlossen habe, kann ich auf meine Daten nicht mehr zugreiffen. Problem ist, dass es in /media dann folgendes gibt Nextcloud, backup, UBSDrive und USBDrive1.

Bitte um Hilfe

Danke im vorraus Schmidt

hast du ggf noch eine festplatte an einem usb-anschluss angesteckt?

dann wĂŒrde ich den stick einstweilen abstecken, das backup auf die usb-festplatte fahren, dann den stick einstecken und das letzte backup per cp oder mv auf der kommandozeile auf den stick kopieren. stick wieder abstecken.

danke fĂŒr die Antwort

ich hab nur 1ne Festplatte am Nextcloudpi.
Wenn ich die 2. Festplatte anstecke, kommt, dass ich keinen Zugriff mehr auf meine Daten habe.
Ich versteh nicht warum ich hab ja dann usb-stick extra mit der bezeichnung “backup” formatiert. Wenn ich mit SSH raufgehe sehe ich das dann auch aber warum USBDrive und USBDrive1 das verstehe ich nicht wenn der 2. Stick angeschlossenwird glaubt Nextcloud das die Datendir. auf dem 2. Stick ist was ja völlig quatsch ist.

ohne jetzt auf dieses verhalten eingehen zu wollen, hatte ich nur versucht, dir einen schnellen workaround zu offerieren


meiner erfahrung nach solltest du den stick mit seiner UUID selbst mounten und in die fstab eintragen. dann sollte das klappen.

Ok dachte sollte es genauer erklÀren.

Soll ich beide selber in die fstab eintragen?

ich habe damit sehr gute erfahrungen gemacht

danke, also automount raus und manuel in die fstab rein.

Muss ich dann noch auf irgendetwas bezĂŒglich Datenbank oder Datadirektion achten?

zur sicherheit trage erstmal nur den stick ein. der rest sollte unnötig sein. hoffe ich.

meinst du den fĂŒr das Backup oder den fĂŒr die Datenbank?

und automount deaktivieren?

meine fstab sieht wie folgt aus

PARTUUID=806c6b0b-01  /boot           vfat    defaults          0       2
PARTUUID=806c6b0b-02  /               ext4    defaults,noatime  0       1
UUID=9a079510-2628-4074-b508-4909e5552547       /media/Nextcloud        ext4
UUID=98f2cfef-bcea-49bc-ba54-52af264963ff       /media/backup   ext4

soll ich bei options und dump und pass was eintragen?

den fĂŒr das backup. aber wenn du beide in der fstab hast, kann das nicht schaden. dann wĂŒrde ich automount auch deaktivieren.

deine eintrĂ€ge sehen zumindest gut aus. bei options und dump bin ich ĂŒberfragt.

und auf diese art und weise geht es immer noch nciht?

Hallo,
ich habe nun ein Problem. Ich habe Automount deaktiviert und und in fstab meine zweite Festplatte eingetragen, die ich fĂŒrs Backup nutzen wollte. Leider habe ich die aktuelle Festplatte mit den “Produktivdaten” vergessen. Nun ist komischerweise meine Nextcloudpi nach einem normalen Reboot gar nicht mehr erreichbar.
Die aktive Festplatte ist ĂŒber BTRFS gemountet, wenn ich das richtig verstehe. HĂ€tte ich die neue Festplatte auch entsprechend mounten mĂŒssen?
Wisst ihr, warum ich die Nextcloud nun gar nicht mehr erreichen kann? In der Fritzbox erscheint das GerÀt auch unter Netzwerk gar nicht mehr.

zieh doch mal die backup platte ab
 und lies das wiki zu dem punkt bei nextcloudpi.com