Nextcloudpi backup problems

Hello to everybody,

it´s the first time that i´m here. I come from Germany and i hope my english is not so bad and you can understand me.

A half year ago i installed nextcloudpi on raspberry pi, It works well but taday i tried to make an backup.
first of all i saw this video: https://www.youtube.com/watch?v=FV80ZE9t6cE.
I logged in as admin.
I tried to do the same, but in the box under the Button RUN appeared a lot of text and the procedure failed.

Next i read a tutorial from github/nextcloud/nextcloudpi/wiki/how-to-backup-and-restore-a-nextcloudpi-instance-using-ncp-config.
I loged in over putty an went pr nc-backup. My destination directory was /media/USBstick2 because the backup should be written on an usbstick which i want to unmount after the backup.
Then appeared a lot of text, you can see in the added screenshot.

I don´t know what to do now. Is there anybody who can help me?

Hi @Doris78H

Thanks for reporting.
Could you please provide output of

df -h

and

sudo ncp-report

Please use pastebin or similar and post the link to it here.

Also have a few questions:
1 Did you include data in your backup?
2 Did you format the usb-stick?
3 Did you have automount enabled?

Thanks for your help.
After i wrote my first post, i read some more posts here and found an important other point the voltage. I use a ssd for data storage on a usb port of my raspberry.
After that i tried it with an old usb2-hub with external power adapter - and - it works!!
The next problem is, that the backup *.tar file was written on my data storage /dev/sda. The destination i´d like should be an other external device like an usb stick.
1 I used the ncp menupoint nc-backup, i don´t know where i can include data there.
2 Yes i formated my usb-stick mit menu point nc format after i switched my “normal” datadevice off because there ist told that nc-format will format all usb devices.
3 Yes i enabled automount.
When i automount the formated usb-stick, the usb ssd device, so far dev/sda, disappeares an the usb stick is now dev/sda - and the ncp status check tells me - “not OK”.
I don´t what the mistake is. pherhaps you have an idea what i do wrong.