NextcloudPI activation

Hi All,

First of all, thanks for the great job you do for delivering this great tool to set up a Nextcloud server.

I am experiencing a problem with the first activation on NextcloudPI.
I have flashed a new raspian Os 64 bit (bullseye) on a raspberry PI 4. Then I set up the static address to be 192.168.1.2. I then ran:

curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | sudo bash

The installation succeeds and tells me to click on https://192.168.1.2 to activate nextcloud and create the password for user ncp. I accept the browser exception, but when I get to the nextcloud web page I face the error:
access through untrusted domain
file config/config.php doesn’t have 192.168.1.2 listed in the trusted domains
I am running the configuration from a remote host through an SSH connection.

How can I solve this?
Thanks

Try defining a trusted domain under port :4443 or ncp-config

You might also want to read Nextcloud admin documentation.

When ncp succesfully finishes, it tells to click on https://192.168.1.2
This is what the doc for nextcloudpi (not nextcloud) say.
https://docs.nextcloudpi.com/en/how-to-access-nextcloudpi/

This is what I was expecting. I haven’t done anything other than flashing a clean raspbian os and running the nextcloudpi curl command.

You will need to define a trusted domain under port :4443 or ncp-config.

I don’t know how you want to access your device, but https and broader internet access will mean adding a domain or setting up something like duckdns.

I am in my internal LAN, no need for duckdns
Adding duckdns can happen after I have activated nextcloud

Great, then all you need to do is add the ip to your trusted domains.

Try adding a trusted domain under the webui at 192.168.1.2:4443 or ncp-config

Okay, if you run into trusted domains errors just be sure to define them and you’ll be fine.

NC init done
/home/pi
Done.

First: Visit https://192.168.1.2/  https://nextcloudpi.local/ (also https://nextcloudpi.lan/ or https://nextcloudpi/ on windows and mac)
to activate your instance of NC, and save the auto generated passwords. You may review or reset them
anytime by using nc-admin and nc-passwd.

When I click on those links I get " Access through untrusted domain". This is just after a fresh raspbian OS 64 bits installation.
How is it possible that I don’t get the activation page?

If I then add 192.168.1.2 to the config/config.php and then I do https://192.168.1.2 I get the login page. But there is no user set, so how am I supposed to login?

Can someone help me to sort this?
Is it just me experiencing this on a fresh installation?

Thanks

You can define a trusted domain under https://192.168.1.2:4443 via the webui. Or, by ssh’ing into your device and accessing ncp-config from the console.

If everything is supposed to auto-configure it by itself, why should I add lines to the trusted domain?
Also, ncp-config keeps telling me that:

Running nc-admin
  'memcache.local' => '\OC\Memcache\Redis',
  'memcache.locking' => '\OC\Memcache\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
    'password' => 'default',
  ),
);
Nextcloud is not installed - only a limited number of commands are available

                                                          
  There are no commands defined in the "user" namespace.  
                                                          

Done. Press any key...

After ncp completes the installation, run sudo reboot.
After the reboot, the activation page will be shown at https://192.168.1.2.
This solved the problem!