NextCloudPi 1.3.12 update adding public IP to trusted domains

Hi everyone. I just finished backing up my data and config settings in anticipation of updating to the most recent version of NextCloudPi. I noticed that ‘add public IP to trusted domains’ is one of the new features for update version 1.3.12. I’m not entirely sure what that means and couldn’t find anything about it using web searches, so I wanted to ask here before updating. I usually have several trusted domain errors in my NextCloud log from login attempts using my public IP address. I have a DDNS account that I use to access my NC server remotely and wanted to make sure that this update wouldn’t open my server up to these attacks that typically get discarded if someone tries to login using my public IP. I just don’t understand what the update entails and don’t want to take any chances without understanding it first. I apologize if I’ve missed something obvious, and I appreciate any guidance that you all can provide. Thanks!

The new tool allows one to add a trusted domain, without having to use command line or manually editing config.php. It does not do anything automatically, and will not change current settings, unless you run the app.

Hi Oliver. Sorry for the late reply. Had some things going on that prevented me from working on much of anything for the past several days. Thank you very much for the information. That actually makes a lot of sense and will no doubt be incredibly helpful for users. I tried running the update and now I’m seeing the dreaded “Error: No information about packages! (Maybe no deb entries?)” output. I know this isn’t an issue that is unique to NextCloudPi, but any help you would be willing to lend would be very much appreciated. I’ve read that this occasionally happens when folks try to install webmin on various Linux distros, and I do have webmin installed on the NextcloudPi just so I can check the status of things without having to sit down at a terminal. I’ve tried going through some steps that I’ve found on some Stack Exchange questions, but they always cause additional problems. Most notably breaking my webmin installation. Any ideas? I am an IT guy, so I don’t have any problem troubleshooting potential solutions, but I’ve mainly had to work with Windows environments in my daily work for the last few years. I also work with Debian and derivatives on a semi-regular basis, so it’s not completely foreign to me. I do take regular backups of my OS partition and data on the NC drives, so I won’t lose anything if something breaks. Thanks again.