Nextcloudcmd no longer has the --path option

Nextcloud Version Nextcloud version 3.2.4git
Operating system and version (eg, Ubuntu 20.04): Red Hat Enterprise Linux 8.8
Apache or nginx version (eg, Apache 2.4.25): Not relevant
PHP version (eg, 7.4): Not relevant

I am setting up syncing some folders from my Nextcloud Server to my local server using nextcloudcmd from nextcloud-client

Using the Nextcloud Documentation I inserted the option --path to pick one folder, but it is no longer an option. You have to refer to a file with a list of folders to exclude. This seems back to front to me.

Steps to replicate it:

  1. nextcloudcmd --path <FOLDER TO SYNC> -u <USER> -p <PASSWD> <LOCAL FOLDER> https://<MY_SERVER_URL>

The output of This command is the Usage as per nextcloudcmd --help

nextcloudcmd - command line Nextcloud client tool
Usage: nextcloudcmd [OPTION] <source_dir> <server_url>
A proxy can either be set manually using --httpproxy.
Otherwise, the setting from a configured sync client will be used.
Options:
  --silent, -s           Don't be so verbose
  --httpproxy [proxy]    Specify a http proxy to use.
                         Proxy is http://server:port
  --trust                Trust the SSL certification.
  --exclude [file]       Exclude list file
  --unsyncedfolders [file]    File containing the list of unsynced remote folders (selective sync)
  --user, -u [name]      Use [name] as the login name
  --password, -p [pass]  Use [pass] as password
  -n                     Use netrc (5) for login
  --non-interactive      Do not block execution with interaction
  --nonshib              Use Non Shibboleth WebDAV authentication
  --davpath [path]       Custom themed dav path, overrides --nonshib
  --max-sync-retries [n] Retries maximum n times (default to 3)
  --uplimit [n]          Limit the upload speed of files to n KB/s
  --downlimit [n]        Limit the download speed of files to n KB/s
  -h                     Sync hidden files, do not ignore them
  --version, -v          Display version and exit
  --logdebug             More verbose logging

There is no option --path now.
Is there a work around, or do I have to keep updating an exclusion file containing a list of folders to exclude?

There is a --path but you’re running a very old version of the client. I think there was some weirdness with that parameter about v3.2.4, but it was fully restored in v3.3.2. You’re likely looking at docs for >v3.2.

You’ll have to upgrade your client to something more recent to get the parameter.

1 Like

Thanks you for pointing this out, @jtr
My Red Hat Enterprise Linux System version 8.8 is providing version 3.2.4git however one of my Gentoo Systems has version 3.8.2-r1 which is way ahead.

Looks like I need to switch my sync to the Gentoo System.

Regards

2 Likes