Nextcloud Web Login will not work - While app and CalDAV access retained

I will try to be as concise as possible.
I accidentally deleted the appdata_******* folder and all its content.
I subsequently tried re-installing nextcloud, retaining the data, but this would not allow the folder to be repopulated.
I then tried the command ooc config:system:delete instanceid twice, and the result is that now in /nextcloud_data/ I have 3 different appdata folders, only 1 of which that can be opened and is included in the config.php configuration file.
That one that can be opened contains only 3 folders, js, preview, theming.

Currently, browser login doesn’t work for any user (spinning of the “loading”, remains locked out).
At the same time, mobile and desktop apps, as well as CalDAV and contacts work flawlessly

Here you can find the outcome of nextcloud.log
https://pastebin.com/1gXYBRe4

Any help will be greatly appreciated!!

Nextcloud version 15:
Operating system and version (eg, Ubuntu 18.04):
nginx version (nginx 1.10.3):
PHP version (eg, 7.0.):

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'passwordsalt' => 'oACW+9nDDOgXPviwLDThYvFZNBJInz',
  'secret' => '3Q/nLEKsxqLe0xrBXw9x9z+tJgWeYdVtI3EaIkumJmYlnaDc',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => '*',
  ),
  'datadirectory' => '/mnt/*****/dietpi_userdata/nextcloud_data',
  'dbtype' => 'mysql',
  'version' => '15.0.5.3',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => true,
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
  ),
  'overwrite.cli.url' => 'http://localhost/nextcloud',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'oc_edoardo',
  'dbpassword' => 'KHVFJMVJDMNkwWRjmH4X7pHFBGR23NVd',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'instanceid' => 'oc5w6vr5ldcu',
);

It might be worth of note that user ‘’‘edoardo’’’ had been originally deleted and subsequently replaced with ed as administrator
The output of your Apache/nginx/system log in /var/log/____:

Thank you in advance for any help!
Best regards,

Edoardo