Nextcloud Version 21 ... All files Corrupt When Downloading


I upgraded to version 21.0.1 from version 19 this past weekend. Everything looked like it went fine … but now ANY file i try to download seems to get “corrupted” in the transfer … and will not open.

The files are just fine … but, Nextcloud downloads of them are all “bad”. I can open them just fine on my computer.

I’m lost at this point.

Additionally, “thumbnails” and download sof image files are broken. I get about the top 30% of the image … and then “blank gray space”.

It’s like “cache” someplace needs to be flushed.

Anybody have a suggestion?

Thank you.



I have the same problem, I thought I had done a bad manipulation of the encryption. It reassures me a little.

I have also updated 21.0.1 from 20.0.8

My data are on a smb server, without any data loss.

Thks, FullMetal. There’s comfort in knowing somebody else is seeing this.

Here is probably a workaround: Files on SMB-share corrupted while up- and downloading · Issue #26457 · nextcloud/server · GitHub

Hello @szaimen ,

First of all, thank you for your reactivity, I just made a copy of the “icewind” folder but I can’t access my server after the copy of this folder, I had kept the folder by renaming it.
I had kept the folder by renaming it. So I went back and wait patiently for the update.

i had the same issue, if you copied it in linux/ubuntu you might need to chown the dir and subdirs to www-data:www-data if they are now owned by root

Thank you very much @nextcloud-cli,

I had forgotten this parameter, that’s what being a novice in the world of linux is all about…

Please consider using the issue template. Here, it is essential to know if the encryption app is involved and as well if this happens on local or external storage. If you don’t manage this properly, you start to mix a lot of potential unrelated problems together.

Thank you szaimen. Your suggestion worked. I just replaced the “icewind” directory with one from my last back-up … and changed permissions recursively from “root” to “www-data” as outlined in the link you provided. It worked.