Nextcloud updates 10.0.2 and 9.0.55 are available, time to update!

I don’t see that error message anywhere in our source code. Please post the complete original error message!!! Thanks :wink:

1 Like

Error message:
Could not start updater, please try the manual update

After That, i am urged to download 10.0.2 manually!

I tried using the updater to update from 10.0.1 to 10.0.2. First try I had an “open_basedir” permission error as I only added "/srv/www/nextcloud’ and not ‘/srv/www’. After fixing this it worked fine. When the updater was done (all checkmarks) I switched ‘maintenance_mode’ off and clicked on the link saying ‘go back to your nextcloud instance’. Then I was greeted with a “Update needed - Please use the command line updater because you have a big instance.” though.

Edit: Next I ran the ‘updater.phar’ and everything was fine again. Thanks.

Can anybody tell me if I put “tmp” in the wrong location or if I should just delete it to run the update and then reopen the folder - or should I better wait for a revised updater?

Hi, I tried the updater from 10.0.1 to 10.0.2 on a raspberry pi setup with nginx, it does not work.
On another setup (webhoster, apache) everythink worked well.
Is there anything I can do to make the updater work with my nginx setup?

Best regards, Stefan

It is a crazy career that we have selected. If we do our jobs well, no one says anything. If something doesn’t work then we hear all about it. :slight_smile: I am not a programmer but I appreciate all the work that you all have done on Nextcloud.

I have a test 10.0.1 system that was originally installed using 10.0.1 and when I try to use the new ‘Nextcloud Updater’ I see this notice below. Do you know what ‘assets’ it is referring to and where I might start looking in order to troubleshoot?

> Initializing
> Current version is 10.0.1.
> Update to Nextcloud 10.0.2 available. (channel: “stable”)

> Check for expected files
> The following extra files have been found:
> assets

thanks!

Just delete that directory. Nextcloud doesn’t use/handle assets.

(It was an old option" in ownCloud", obsolete now. You can also delete the line ‘asset-pipeline.enabled’ => true/false, if you stlll have it in your config.php)

Thank you for responding. Just to confirm, you are recommending that I simply delete the obsolete “/var/www/nextcloud/assets” directory?

Yes ! :slight_smile:

1 Like

This happens if the POST to the updater endpoint fails. Can you check in your browsers network console what the response to the POST request to /updater/ is alike?

Nextcloud doesn’t put any tmp folder there. This seems to be done by you or your hoster. If you are confident that the content is not needed you can delete the folder. Also make sure that it is actually not configured as your temporary folder in your PHP.

Having sensitive data like the temp folder in the web root can also be a security problem.

Excellent. Thanks also for encouraging me to check the config.php to see if the obsolete folder was referenced there also. It was not but I believe in cleaning up where possible. :slight_smile:

NOTE - after removing the “assets” folder under the Nextcloud www folder, I tried the web interface updater and it worked perfect.

thank you!

Dear Lukas,

I did put the temp folder there.

It sits in …/KUNDENNUMMER/nextcloud/…

Do reference root folder to the overall structure or is the root-folder just the folder the nextcloud-installation is in?

Is there a recommended location for a temp folder for a hosted enviroment on an apache webhoster like domainfactory from you?

thanks!

I had 10.0.1 installed and saw this:


=> The notification shows the wrong version!

No that’s an internal version number (relict from owncloud days). This will be cleaned up in NC 11 (https://github.com/nextcloud/server/issues/1605).

enclosed you’ll find the screen shot of the console output!

The directory exists, containing a file named index.php

regards, hitam4450

After deleting the assets folder the updater worked like a charm. Great work, guys!

To solve the permission issues quickly, I have 2 scripts. One setting the permissions for the update process and one to set them for production, Sure it would be much more convenient if the updater would do that but I’m OK with how it is. That way I always know which permissions are set.

2 posts were split to a new topic: Integritätscheck -> asset folder

There are more and more individual support request. Please open individual threads for these, it’s better to discuss only one issue at a time. This makes it easier for others to find existing solutions.

Closing here.

1 Like