Nextcloud Talk - failed to connect to

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 25.0.3
Operating system and version (eg, Ubuntu 20.04): AlmaLinux 8.7
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.37
PHP version (eg, 7.4): 7.4.30

The issue you are facing:
When attempting to use the Talk Android client internally on WLAN I get the message: “failed to connect to” (but, of course, it displays my actual public domain name and public IP address in the the client). I have no issues with Talk within the web browser on my LAN nor using the Android client external of my LAN. In other words, if I turn off my Wi-Fi on my phone and attempt to connect to I can connect and login just fine. But when I turn on my Wi-Fi is when I get the connection failure. Weirdness.
I am self-hosting Nextcloud on a web server on my LAN. I have a separate server running Nginx Proxy Manager as a frontend pointing at my web server.

The NPM configuration:

Details Tab:
Domain Names:
Scheme: http
Forward: web_serverlanip
Forward Port: 80

SSL Tab: certificate is selected. Force SSL and HSTS Enabled is also selected

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. While on WLAN, open Talk Android client and enter
  2. While on WLAN, open Talk Android client and enter

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'x',
  'passwordsalt' => 'x',
  'secret' => 'x',
  'trusted_domains' =>
  array (
    0 => 'serverlanip',
    1 => 'serverhostname',
    2 => 'serverfqdn',
    3 => '',
  'datadirectory' => '/path/to/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwriteprotocol' => 'https',
  'overwrite.cli.url' => 'http://serverlanip',
  'dbname' => 'nextclouddb_name',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextclouddb_username',
  'dbpassword' => 'blahblah_Im_not_telling',
  'installed' => true,
  'updater.secret' => 'x',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____:



Output errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors. Use a pastebin service if necessary.


Any thoughts at all on the issue?

I’ve tried different configurations with no resolution. I even setup a STUN/TURN server and it didn’t solve the problem.

One thing that doesn’t really help is that the client is on Android that doesn’t produce any logs so it’s tough to troubleshoot the smartphone part.

So, is this a conundrum, or what? I still haven’t found a solution to this problem.