Nextcloud Talk - Before it was "almost" it stops completely


I was, until today, to Nextcloud 21 with Talk app 11.x.

I have upgrated both to Nextcloud 22 and Talk 12.

I was able (almost) to get this Talk thing working, a bit, with Coturn, as TURN server, for video and audio calls (even if I have experienced a lot of issues on Lenovo tablets, for example, with Nextcloud app not responding while calling from another device).

After the upgrade to Talk 12 even this limping configuration has stopped completely. TURN configuration is still the same, but Nextcloud Android app is even more slower than before (upgraded to the latest, 12), the Talk app, on Chrome, Chromium and Brave gives an “encoder already in use” in talk-main.js.

Basically, Talk does not work anymore.

For now I will disable completely this app and will remove the Nextcloud app from my Android devices, as they are completely useless right now.

In the meantime, are there any suggestions about, eventually, Coturn (behind NAT) configurations?

The normal Nextcloud functionality still works, Talk not anymore.

Many thanks and kind regards.

EDIT: in addition…call/video notifications does not work anymore also. The “bell” shows events (call, messages, etc.) but no sounds at all on Android app (even if the app itself has all Android authorizations, no battery optimization, no battery manager involved, etc.).

NC21+Talk11 with a coTURN server works OK with attendees on computers.
It works even better (smoother) with the HPB.
And so does NC22+Talk12…

Haven’t tried with Android clients. It’s most likely the crappy network on the Android phone…

Hello henry,

Could you please share your coturn config (turnserver.conf), if possible?

Also, your TURN server in behind NAT or is it configured with public IP directly?

No, I can’t.
It’s on a public IP with Let’s Encrypt SSL…

Ah ok, so it’s not behind NAT, not the same scenario in which I am.

Thanks anyway.

Where did you install Talk from? If you installed F-Droid version, this behavior is expected, since it doesn’t have the google services needed for push notifications.

Maybe give this a shot?