Nextcloud stürzt nach Erstellen eines Benutzers ab

Liebe Comunity,

ich habe eine neue nextcloud eingerichtet mit der aktuellen Version 11.0. Der Fehler tritt bei mir allerdings auch bei 10.0.2 auf.

Nach klicken auf Benutzer anlegen passiert nichts, beim (neu)laden einer nextcloud-Seite erscheint lediglich eine leere, weiße Seite. Nach ca. einer halben Minute lässt sich das System wieder erreichen.

Hier der Log des letzten Versuches mit 10.0.2:
> {“reqId”:“WF04m8CoLOkAADV5j@wAAABK”,“remoteAddr”:“217.82.60.189”,“app”:“mysql.setup”,“message”:“Specific user creation failed: An exception occurred while executing ‘SELECT user FROM mysql.user WHERE user=?’ with params [“oc__username_”]:\n\nSQLSTATE[42000]: Syntax error or access violation: 1142 SELECT command denied to user ‘U111111’@‘braggi.store.d0m.de’ for table ‘user’”,“level”:3,“time”:“2016-12-23T14:45:48+00:00”,“method”:“POST”,“url”:"/index.php",“user”:"–",“version”:“9.1.2.2”}

{"reqId":"WF04m8CoLOkAADV5j@wAAABK","remoteAddr":"_ip_","app":"mysql.setup","message":"Database creation failed: An exception occurred while executing 'GRANT ALL PRIVILEGES ON `DB_111111_` . * TO _'U111111_':\n\nSQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user '_U111111_'@'192.168.4%' to database '_DB111111_'","level":3,"time":"2016-12-23T14:45:48+00:00","method":"POST","url":"\/index.php","user":"--","version":"9.1.2.2"}
{"reqId":"WF04ycCoLOkAABsMch4AAABO","remoteAddr":"_ip_","app":"PHP","message":"opendir(\/var\/tmp\/): failed to open dir: Permission denied at \/_..._\/nextcloud\/lib\/private\/TempManager.php#189","level":3,"time":"2016-12-23T14:46:33+00:00","method":"GET","url":"\/cron.php","user":"--","version":"9.1.2.2"}
{"reqId":"WF05N8CoLOkAAD8unmwAAAJR","remoteAddr":"_ip_","app":"PHP","message":"opendir(\/var\/tmp\/): failed to open dir: Permission denied at \/_..._\/nextcloud\/lib\/private\/TempManager.php#189","level":3,"time":"2016-12-23T14:48:24+00:00","method":"GET","url":"\/cron.php","user":"--","version":"9.1.2.2"}
{"reqId":"WF05PMCoLOkAAD8unnIAAAJR","remoteAddr":"_ip_","app":"PHP","message":"opendir(\/var\/tmp\/): failed to open dir: Permission denied at \/_..._\/nextcloud\/lib\/private\/TempManager.php#189","level":3,"time":"2016-12-23T14:48:28+00:00","method":"GET","url":"\/cron.php","user":"--","version":"9.1.2.2"}
{"reqId":"WF05PsCoLOkAAG6ExgYAAABF","remoteAddr":"_ip_","app":"PHP","message":"opendir(\/var\/tmp\/): failed to open dir: Permission denied at \/_..._\/nextcloud\/lib\/private\/TempManager.php#189","level":3,"time":"2016-12-23T14:48:30+00:00","method":"GET","url":"\/cron.php","user":"--","version":"9.1.2.2"}
{"reqId":"WF07dMCoLOkAAE@7HNkAAALA","remoteAddr":"_ip_","app":"PHP","message":"opendir(\/var\/tmp\/): failed to open dir: Permission denied at \/_..._\/nextcloud\/lib\/private\/TempManager.php#189","level":3,"time":"2016-12-23T14:57:57+00:00","method":"GET","url":"\/cron.php","user":"--","version":"9.1.2.2"}
{"reqId":"WF07esCoLOkAAD3eAoMAAAFX","remoteAddr":"_ip_","app":"PHP","message":"opendir(\/var\/tmp\/): failed to open dir: Permission denied at \/_..._\/nextcloud\/lib\/private\/TempManager.php#189","level":3,"time":"2016-12-23T14:58:02+00:00","method":"GET","url":"\/cron.php","user":"--","version":"9.1.2.2"}
{"reqId":"WF07n8CoLOkAAEpjFHgAAAGZ","remoteAddr":"_ip_","app":"PHP","message":"opendir(\/var\/tmp\/): failed to open dir: Permission denied at \/_..._\/nextcloud\/lib\/private\/TempManager.php#189","level":3,"time":"2016-12-23T14:58:39+00:00","method":"GET","url":"\/cron.php","user":"--","version":"9.1.2.2"}
{"reqId":"WF07oMCoLOkAAENyD18AAAHL","remoteAddr":"_ip_","app":"PHP","message":"opendir(\/var\/tmp\/): failed to open dir: Permission denied at \/_..._\/nextcloud\/lib\/private\/TempManager.php#189","level":3,"time":"2016-12-23T14:58:40+00:00","method":"GET","url":"\/cron.php","user":"--","version":"9.1.2.2"}

Gehostet ist das ganze bei Strato.
Über Hilfe würde ich mich sehr freuen, da ich ansonsten ein anderes System suchen müsste, ohne Benutzer ist das ganze etwas witzlos.

Danke und weihnachtliche Grüße
Erik

Hallo Erik,

Autsch … Das klingt nicht schön :sweat_smile: …aber ich bin mir sicher - wir bekommen das irgendwie hin :muscle:
Deinem Bericht zufolge, bist du bei STRATO - ich vermute daher Shared Hosting - also kein eigner Server.

Ich würde dir raten - einen Issue auf GitHub aufzumachen … denn dort sind die Entwickler, und die können dir in diesem Fall am besten weiterhelfen. Denn ich kann das jetzt nicht direkt reproduzieren.

Bitte achte darauf, alle Angaben des Issue Templates auszufüllen, damit man dir best- und schnellstmöglich helfen kann - und den Bug fixen kann (sofern es denn einer sein sollte :wink:). Einige Angaben bezüglich des Servers lässt du natürlich weg, da du sie nicht kennst … erwähne, dass du Shared Hosting von STRATO verwendest.

Bitte verlinke auch diesen Theard und mentione mich mit @MariusBluem, damit ich den weiteren Verlauf weiterverfolgen kann :wink:

Ich wünsche dir auch ein frohes Weihnachtsfest!

Viele Grüße

Marius

Für die Zukunft - das englische Forum hat ein vielfaches an Nutzern, und du hast dort höhere Chancen, (schnelle) Hilfe zu bekommen :wink: