Nextcloud stuck in maintanance mode after plugin update

Nextcloud version: (nextcloud:fpm-alpine docker image)
Operating system and version (eg, Ubuntu 20.04): Fedora 32
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1):

The issue you are facing:

After updating some plugins (just the default ones) nextcloud entered maintenance mode. Its been a few days now and it hasn’t changed

Is this the first time you’ve seen this error? (Y/N): Y

The output of your Nextcloud log in Admin > Logging:

Can’t access this but status.php says


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/html/apps',
      'url' => '/apps',
      'writable' => false,
    1 => 
    array (
      'path' => '/var/www/html/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
  'trusted_proxies' => NULL,
  'instanceid' => 'oc6fesd0df73',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' => 
  array (
    2 => 'nextcloud.mydomain',
  'datadirectory' => '/var/www/html/data',
  'dbtype' => 'pgsql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'db',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => '',
  'mail_domain' => '',
  'mail_smtphost' => 'mail.mydomain',
  'maintenance' => true,

What should I do to resolve this? I see other threads saying to just change maintenance to false. Is that safe?

I think yes or perhaps no. Do you have another option? Do you have a backup?

Without shell access configure config/config.php.

Hi @Qwertie,

So hopefully you did a backup of your installation before the addition of the plugin?

You should be fine to change the maintenance mode to ‘false’. It may well be you encounter other errors after this maybe that the plugin introduced?

Which plugin did you install?

Not sure exactly what plugin it was, I was just updating all the default ones like contacts and mail. I think I’ll just set it to false in the config and if it fails I’ll have to reinstall. All my files are safe but I don’t have a backup of the database and stuff.

Edit: Looks like changing the config has fixed it. Or at least I don’t see any issues.

Hi @Qwertie,

That’s great! depending on your DB type mysql / postgres etc you can always do a db dump before upgrades (google is your friend).

If you feel that your issue is solved maybe you can mark this thread as such?