Nextcloud Stops Responding for a few seconds every few seconds

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 23.0.2
Operating system and version (eg, Ubuntu 20.04): Arch Linux
Apache or nginx version (eg, Apache 2.4.25): nginx 1.20.2-1
PHP version (eg, 7.4): 8.1.3-1

The issue you are facing:

Nextcloud stops responding for a few seconds every few seconds. So when I go to click on a menu item on the sidebar it will suddenly stop responding to any mouse movement or mouse clicks or any other events. If the mouse pointer was a hand it will remain a hand for the few seconds it’s frozen and then when nextcloud unfreezes the pointer will turn into a mouse pointer again if im no longer on a menu item.

I’ve noticed this a lot in the logs:
PHP security error: /var/lib/nextcloud/apps/richdocumentscode/proxy.php is not under the default docroot

I basically set it up according to this wiki:
using uwsqi and postgres

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Open nextcloud on any device

The output of your Nextcloud log in Admin > Logging:

[PHP] Error: foreach() argument must be of type array|object, bool given at /usr/share/webapps/nextcloud/apps/serverinfo/lib/OperatingSystems/DefaultOs.php#152

GET /settings/admin/serverinfo
from by admin at 2022-03-05T16:22:18+00:00
[index] Error: SplFileInfo::isDir(): open_basedir restriction in effect. File(/var/lib/nextcloud/apps/..) is not within the allowed path(s): (/var/lib/nextcloud/data:/var/lib/nextcloud/apps:/tmp:/usr/share/webapps/nextcloud:/etc/webapps/nextcloud:/dev/urandom:/usr/lib/php/modules:/var/log/nextcloud:/proc/meminfo)

GET /settings/ajax/checksetup
from by admin at 2022-03-05T16:15:43+00:00

NOTE: Since seeing this error I commented out the open_basedir line in php.ini and /etc/uwsgi/nextcloud.ini

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => '',
  'overwrite.cli.url' => '',
  'htaccess.RewriteBase' => '/',
  'memcache.local' => '\OC\Memcache\APCu',
  'datadirectory' => '/var/lib/nextcloud/data',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/usr/share/webapps/nextcloud/apps',
      'url' => '/apps',
      'writable' => false,
    1 =>
    array (
      'path' => '/var/lib/nextcloud/apps',
      'url' => '/wapps',
      'writable' => true,
  'passwordsalt' => 'xP+Ibs63/TNfU11Xkc23GlxtXHc3T5',
  'secret' => 'LQIuMeSZlclHxefaBWrli7jO0lhjA/WH+lO22G85DyziKkTY',
  'dbtype' => 'pgsql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => '/run/postgresql',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => '1234',
  'installed' => true,
  'instanceid' => 'ocsatj3726cy',
  'maintenance' => false,

The output of your Apache/nginx/system log in /var/log/____:

File is way too big

After disabling Collabora Online - Built-in CODE Server the issue was resolved…but I’d like to enable Collabora Online - Built-in CODE Server