Nextcloud Snap users, please list the issues you're facing

You’re more likely to get help logging issues on the project itself.

I am facing a SSL handshake issue from an android 4.4.2 device.

i have a setup where I sync my contancts on Nextcloud with multiple Android devices using Davx5 (davdroid). It used to work fine but now one of my devices stopped syncing. Don’t know for sure but I have a sense that this could be related to the snap update specific to the Android version because my other android device (and thunderbird as well) is continuing to sync properly.

The error I am getting from Davx5 says:

2019-04-16 10:35:50 2 [HttpClient] <-- HTTP FAILED: SSL handshake aborted: ssl=0x5e210c78: Failure in SSL library, usually a protocol error

error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure (external/openssl/ssl/s23_clnt.c:744 0x5e2b2830:0x00000000)

Full Error Log:

From what I read on Davx5 forums, this could be about incompatible ciphers ( But I am not sure what they are, how to test or change them in a nextcloud snap installation setting.

Any idea how to proceed with troubleshooting?

@qweqweqwe please start a new thread or log an issue.

I have external storage mounted to /media/nextcloud. By default apparmor denies access to this folder. Logs looks like this:

May 23 11:06:58 cloud kernel: [255431.083533] audit: type=1400 audit(1558598818.295:5976): apparmor=“DENIED” operation=“open” profile=“snap.nextcloud.php-fpm” name="/media/nextcloud/data/nextcloud.log" pid=26872 comm=“php-fpm” requested_mask=“ac” denied_mask=“ac” fsuid=0 ouid=0

I can change profile /var/lib/snapd/apparmor/profiles/snap.nextcloud.php-fpm
and nextcloud works fine.
But after each update apparmor replaces this profile and my changes are lost.
How to save my fixes in apparmor profiles and prevent them from changes on update?

today I noticed that my nextcloud box i still on version 13 (13.0.12 to be exact) and wondered, since version 16 seems to be out, shouldn’t the snap version in nextcloud box auto update at some point?

Danger alert: if you are running Nextcloud from a ver. 15 snap, don’t upgrade your “Bookmarks” app to 2.1.1! It needs the php-gmp package/library, which is not in the ver. 15 snap! Stay on “Bookmarks” version 1.1.1.

Note: Cross-posted from here.

Also note: a ver. 16 snap seems to work, for the bookmarks app! Problem only exists with ver. 15 snap.

I installed Nextcloud snap in an Ubuntu 18.04.3 LTS VPS about a month ago, been using it with no issues accesing through the VPS IP with a self-signed certificate for HTTPS.
Today I pointed a to the VPS IP, redirection was successful.
Then I tried to create new certificates for the and everything blew up.

Right now I get the default Apache webpage with no access to nextcloud.

Any ideas how to troubleshoot?

Where to begin?

with HTTPS I get

This site can’t be reached unexpectedly closed the connection.



with HTTP
Default Apache welcome page.

Thanks in advance

HI there,
I’ve just posted an issue as a separate topic:

Not sure whether it’s a snap issue or whether providing a check for the coturn server is all you can do here.
Best regards

Help! for some Reason nextcloud does not show “DESK” and some users can’t login! What I’ve been doing a day before was “nextcloud.export” and it did not gave me any error. What I think is somebody hit update. Is there some clue how can I fix this?


I followed this simple guide on getting Nextcloud setup on a linode server but I cannot get HTTPS enable and only have HTTP which is not a secure connection.

I did everything in the video but I skipped the domain part (Step 4 & 5). I do not want to buy a domain name for my Nextcloud server and I am perfectly fine with remembering an IP address.

How do I get HTTPS to work with the IP address only?

1 Like

I installed NextCloud via SNAP on my Armbian Buster with Linux 5.4.21

But i can not get https to work, is there any fix?
Only Firefox can display my site.

btw. while reading the trusted domains, i get this error msg:

sudo snap run nextcloud.occ config:system:get trusted_domains 1
2020/03/11 00:28:29.305784 cmd_run.go:884: WARNING: cannot create user data directory: failed to verify SELinux context of /root/snap: exec: "matchpathcon": executable file not found in $PATH`
nextcloud.enable-https lets-encrypt
Command 'nextcloud.enable-https' is available in '/snap/bin/nextcloud.enable-https'
The command could not be located because '/snap/bin' is not included in the PATH environment variable.

adding /snap/bin to $PATH
and running:

sudo nextcloud.enable-https lets-encrypt

fixed the issue.

Just installed the snap on a fresh (but fully updated) Ubuntu 18.04.1 lxc image (provided by ProxMox) running on ProxMox VE 6.1-2.

After logging in, I get an indefinite “Problem loading page, reloading in 3, 2, 1…”

/var/log/syslog shows nothing, but dmesg shows this:

[ 4667.578171] audit: type=1400 audit(1586126679.304:156): apparmor="STATUS" operation="profile_load" label="lxc-100_</var/lib/lxc>//&:lxc-100_<-var-lib-lxc>:unconfined" name="/sbin/dhclient" pid=5555 comm="apparmor_parser"
[ 4667.582116] audit: type=1400 audit(1586126679.304:157): apparmor="STATUS" operation="profile_load" label="lxc-100_</var/lib/lxc>//&:lxc-100_<-var-lib-lxc>:unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=5555 comm="apparmor_parser"
[ 4667.586022] audit: type=1400 audit(1586126679.304:158): apparmor="STATUS" operation="profile_load" label="lxc-100_</var/lib/lxc>//&:lxc-100_<-var-lib-lxc>:unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=5555 comm="apparmor_parser"
[ 4667.589951] audit: type=1400 audit(1586126679.304:159): apparmor="STATUS" operation="profile_load" label="lxc-100_</var/lib/lxc>//&:lxc-100_<-var-lib-lxc>:unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=5555 comm="apparmor_parser"
[ 4667.593862] audit: type=1400 audit(1586126679.308:160): apparmor="STATUS" operation="profile_load" label="lxc-100_</var/lib/lxc>//&:lxc-100_<-var-lib-lxc>:unconfined" name="/usr/sbin/tcpdump" pid=5559 comm="apparmor_parser"
[ 4667.597773] audit: type=1400 audit(1586126679.308:161): apparmor="STATUS" operation="profile_load" label="lxc-100_</var/lib/lxc>//&:lxc-100_<-var-lib-lxc>:unconfined" name="/usr/lib/snapd/snap-confine" pid=5557 comm="apparmor_parser"
[ 4667.601684] audit: type=1400 audit(1586126679.308:162): apparmor="STATUS" operation="profile_load" label="lxc-100_</var/lib/lxc>//&:lxc-100_<-var-lib-lxc>:unconfined" name="/usr/lib/snapd/snap-confine//mount-namespace-capture-helper" pid=5557 comm="apparmor_parser"
[ 4672.503480] kauditd_printk_skb: 26 callbacks suppressed
[ 4672.503490] audit: type=1400 audit(1586126684.232:189): apparmor="DENIED" operation="exec" namespace="root//lxc-100_<-var-lib-lxc>" profile="snap.nextcloud.mysql" name="/bin/systemctl" pid=6265 comm="mysql.server" requested_mask="x" denied_mask="x" fsuid=100000 ouid=100000
[ 4672.568160] audit: type=1400 audit(1586126684.296:190): apparmor="DENIED" operation="open" namespace="root//lxc-100_<-var-lib-lxc>" profile="snap.nextcloud.renew-certs" name="/proc/672/mounts" pid=6156 comm="python2" requested_mask="r" denied_mask="r" fsuid=100000 ouid=100000
[ 4676.629824] audit: type=1400 audit(1586126688.356:191): apparmor="DENIED" operation="file_mmap" namespace="root//lxc-100_<-var-lib-lxc>" profile="snap.nextcloud.php-fpm" name="/" pid=6609 comm="php-fpm" requested_mask="w" denied_mask="w" fsuid=100000 ouid=100000

So, this sounds to me like AppArmor is a little too aggressive, but I have no clue how to fix this (without me risking breaking AppArmor). Any ideas?


Nextcloud version ** 17.0.5 **
Operating system and version (Ubuntu 18.04 LTS):
Apache or nginx version (Unknown):
PHP version (Unkown):

The issue you are facing:

Nextcloud desktop client starts going into “Not Responding” after transferring about 50gbs of data to nextcloud server.

Is this the first time you’ve seen this error? (Y/N) : Yes

Steps to replicate it:

  1. Start Nextcloud app
  2. Reviews local files for what needs to be synced
  3. Starts to transfer files to Nextcloud server and starts Not Responding then responds then Not responding about 20 sec cycles

The output of your Nextcloud log in Admin > Logging :

Error	PHP	Invalid argument supplied for foreach() at /snap/nextcloud/20007/htdocs/apps/serverinfo/lib/Os.php#155
Error	PHP	Undefined variable: result at /snap/nextcloud/20007/htdocs/apps/serverinfo/lib/OperatingSystems/DefaultOs.php#173
Error	PHP	Invalid argument supplied for foreach() at /snap/nextcloud/20007/htdocs/apps/serverinfo/templates/settings-admin.php#101
Error	PHP	Undefined variable: result at /snap/nextcloud/20007/htdocs/apps/serverinfo/lib/OperatingSystems/DefaultOs.php#173
Fatal	webdav	Sabre\DAV\Exception\BadRequest: Expected filesize of 88187282 bytes but read (from Nextcloud client) and wrote (to Nextcloud storage) 55951360 bytes. Could either be a network problem on the sending side or a problem writing to the storage on the server side
Fatal	webdav	Sabre\DAV\Exception\BadRequest: Expected filesize of 15007270 bytes but read (from Nextcloud client) and wrote (to Nextcloud storage) 11370496 bytes. Could either be a network problem on the sending side or a problem writing to the storage on the server side.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/snap/nextcloud/current/htdocs/apps',
      'url' => '/apps',
      'writable' => false,
    1 =>
    array (
      'path' => '/var/snap/nextcloud/current/nextcloud/extra-apps',
      'url' => '/extra-apps',
      'writable' => true,
  'supportedDatabases' =>
  array (
    0 => 'mysql',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/tmp/sockets/redis.sock',
    'port' => 0,
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' =>
  array (
    0 => '',
  'datadirectory' => '/var/snap/nextcloud/common/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:/tmp/sockets/mysql.sock',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____ :

Using snap version can't find log file

Hi there, just installed latest NC snap on Ubuntu 20.04. Everything installed and configured correctly but when I try to access from my domain I get the landing page but no login prompt?Screenshot from 2020-10-20 15-10-56(1)
The page takes a long time to load. I have no problem accessing from the local address and have already tried reinstalling it and have only install the recommended apps. I am using an up to date version of chromium with no addons installed either.
I am a relative noob at this so please go easy on me. Any help you can provide would be greatly appreciated!
N.B. I have created a separate post (New NC snap install, no login prompt?) for this issue and thought it should be bought to your attention. Looks like others are getting the same problem.

The biggest issue I am having is lack of documentation for the snap installation. All the documentation is for standard install and most of it does not apply. I have to follow a bunch of threads to figure out if what I want to do is possible with snap.

Also relating to documentation: I also didn’t know about the VMs available. I probably would have used that instead of snap.

1 Like

FYI, I do not monitor this topic, and I don’t believe any other snap maintainers do, either. If you’re having an issue, I encourage you to log an issue in the place we actually monitor, or at the very least create a new topic here specific to your issue so it can be properly debugged. @staff can we please lock this?

hello I got a very seriuos problem, any command deployed shows some output like that:
An unhandled exception has been thrown:
Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occurred in driver: SQLSTATE[HY000] [1045] Access denied for user ‘nextcloud’@‘localhost’ (using password: YES) in /snap/nextcloud/23743/htdocs/lib/private/DB/Connection.php:67
Stack trace:
#0 /snap/nextcloud/23743/htdocs/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(889): OC\DB\Connection->connect()
#1 /snap/nextcloud/23743/htdocs/lib/private/DB/Connection.php(194): Doctrine\DBAL\Connection->executeQuery(‘SELECT * FROM ...', Array, Array, NULL) #2 /snap/nextcloud/23743/htdocs/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Query/QueryBuilder.php(200): OC\DB\Connection->executeQuery('SELECT * FROM …’, Array, Array)
#3 /snap/nextcloud/23743/htdocs/lib/private/DB/QueryBuilder/QueryBuilder.php(216): Doctrine\DBAL\Query\QueryBuilder->execute()
#4 /snap/nextcloud/23743/htdocs/lib/private/AppConfig.php(331): OC\DB\QueryBuilder\QueryBuilder->execute()
#5 /snap/nextcloud/23743/htdocs/lib/private/AppConfig.php(109): OC\AppConfig->loadConfigValues()
#6 /snap/nextcloud/23743/htdocs/lib/private/AppConfig.php(287): OC\AppConfig->getApps()
#7 /snap/nextcloud/23743/htdocs/lib/private/legacy/OC_App.php(883): OC\AppConfig->getValues(false, ‘installed_versi…’)
#8 /snap/nextcloud/23743/htdocs/lib/private/Server.php(665): OC_App::getAppVersions()
#9 /snap/nextcloud/23743/htdocs/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\Server->OC{closure}(Object(OC\Server))
#10 /snap/nextcloud/23743/htdocs/lib/private/ServerContainer.php(124): Pimple\Container->offsetGet(‘OC\Memcache\Fac…’)
#11 /snap/nextcloud/23743/htdocs/lib/private/Server.php(1704): OC\ServerContainer->query(‘OC\Memcache\Fac…’)
#12 /snap/nextcloud/23743/htdocs/lib/private/Server.php(856): OC\Server->getMemCacheFactory()
#13 /snap/nextcloud/23743/htdocs/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\Server->OC{closure}(Object(OC\Server))
#14 /snap/nextcloud/23743/htdocs/lib/private/ServerContainer.php(124): Pimple\Container->offsetGet(‘OC\App\AppManag…’)
#15 /snap/nextcloud/23743/htdocs/lib/private/AppFramework/Utility/SimpleContainer.php(163): OC\ServerContainer->query(‘OC\App\AppManag…’)
#16 /snap/nextcloud/23743/htdocs/3rdparty/pimple/pimple/src/Pimple/Container.php(114): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility{closure}(Object(OC\Server))
#17 /snap/nextcloud/23743/htdocs/lib/private/ServerContainer.php(124): Pimple\Container->offsetGet(‘OCP\App\IAppMan…’)
#18 /snap/nextcloud/23743/htdocs/lib/private/Server.php(1894): OC\ServerContainer->query(‘OCP\App\IAppMan…’)
#19 /snap/nextcloud/23743/htdocs/lib/private/legacy/OC_App.php(347): OC\Server->getAppManager()
#20 /snap/nextcloud/23743/htdocs/lib/private/legacy/OC_App.php(114): OC_App::getEnabledApps()
#21 /snap/nextcloud/23743/htdocs/lib/base.php(648): OC_App::loadApps(Array)
#22 /snap/nextcloud/23743/htdocs/lib/base.php(1094): OC::init()
#23 /snap/nextcloud/23743/htdocs/console.php(49): require_once(’/snap/nextcloud…’)
#24 /snap/nextcloud/23743/htdocs/occ(11): require_once(’/snap/nextcloud…’)
#25 {main}


I installed Nextcloud via Snap on my Raspberry Pi. I had it shutdown for a while. Now i started it again and Nextcloud did not run.

I tried:
sudo snap restart nextcloud.php-fpm

and got this:

error: cannot communicate with server: Post http://localhost/v2/apps: dial unix /run/snapd.socket: connect: connection refused

I found no fitting solution for my problem online.

Closing this here.

For reasons see post Nextcloud Snap users, please list the issues you're facing